Download it now!
Bug 103867 - Scrolling with Conditional Formatting Not Smooth
Summary: Scrolling with Conditional Formatting Not Smooth
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha1+
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace, regression
Depends on:
Blocks: Conditional-Formatting GTK3
  Show dependency treegraph
 
Reported: 2016-11-11 15:14 UTC by Joel Madero
Modified: 2017-07-28 12:02 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Basic file with 1 column of conditional formatting (16.29 KB, application/vnd.oasis.opendocument.spreadsheet)
2016-11-11 15:14 UTC, Joel Madero
Details
Callgrind (6.44 MB, application/x-bzip)
2016-11-25 18:38 UTC, Joel Madero
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Joel Madero 2016-11-11 15:14:54 UTC
Created attachment 128663 [details]
Basic file with 1 column of conditional formatting

BROKEN:
Version: 5.3.0.0.alpha1+
Build ID: c64b8ffe851d3320a15071fa4bc4b0f12e9939d5
CPU Threads: 2; OS Version: Linux 4.4; UI Render: default; VCL: gtk3; Layout Engine: new; 
Locale: en-US (en_US.UTF-8); Calc: group


WORKS:
Version: 5.2.3.2
Build ID: 1:5.2.3~rc2-0ubuntu1~xenial1
CPU Threads: 2; OS Version: Linux 4.4; UI Render: default; 
Locale: en-US (en_US.UTF-8); Calc: group

REPRO STEPS:
1. Open attached document;
2. Try scrolling with mouse

Observed: Scrolling is not smooth, jumpy and laggy

Expected: Smooth scrolling, no jumping, no lag
Comment 1 m.a.riosv 2016-11-11 16:41:22 UTC
No problem with:
Version: 5.3.0.0.alpha1+
Build ID: f6391d9696bfa7485bf785ac81edef4d5441e232
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; Layout Engine: new; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-11-09_23:49:38
Locale: es-ES (es_ES); Calc: single
Comment 2 Joel Madero 2016-11-11 21:22:48 UTC
Bodhi Linux 4 - Built on Ubuntu 16.04 using Moksha DE (fork of E17)
Comment 3 Xisco Faulí 2016-11-12 01:27:46 UTC
I can't reproduce it in

Version: 5.3.0.0.alpha1+
Build ID: 60da087d7e182b58b63d4123c9bd96c82376d450
CPU Threads: 4; OS Version: Linux 4.2; UI Render: default; VCL: gtk3; Layout Engine: new; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 4 Buovjaga 2016-11-25 14:52:16 UTC Comment hidden (obsolete)
Comment 5 Joel Madero 2016-11-25 18:38:29 UTC
Created attachment 129013 [details]
Callgrind

Apparently this is a GTK issue, callgrind is attached.
Comment 6 Joel Madero 2016-11-25 18:41:11 UTC
Caolan - seems like GTK is causing some hiccups. This callgrind should show the issue with scrolling as well as load times up to 10x longer than when I run "SAL_USE_VCLPLUGIN=gtk ./soffice"
Comment 7 Buovjaga 2016-11-25 20:06:27 UTC
Huh, I built LibO in a Bodhi VM, but could not reproduce :(
The file opens quickly and scrolls normally with gtk3.

Version: 5.4.0.0.alpha0+
Build ID: 7c43cba9804e70b23b71783d362401c75f9caa54
CPU Threads: 4; OS Version: Linux 4.4; UI Render: default; VCL: gtk3; Layout Engine: new; 
Locale: en-US (en_US.UTF-8); Calc: group
Comment 8 Heiko Tietze 2017-02-21 16:59:09 UTC
Scrolling smoothly.
Comment 9 3191602956 2017-04-14 23:46:07 UTC
Not scrolling smoothly for me. Just downloaded LO 5.3.2.2 and in Calc, the scrolling is stepped. One row at a time, regardless of the speed of scrolling. 

Scrolling in Writer is even worse. It jumps over a number of lines at a single move of the mouse wheel.
Comment 10 Buovjaga 2017-04-15 17:41:55 UTC
(In reply to 3191602956 from comment #9)
> Not scrolling smoothly for me. Just downloaded LO 5.3.2.2 and in Calc, the
> scrolling is stepped. One row at a time, regardless of the speed of
> scrolling. 
> 
> Scrolling in Writer is even worse. It jumps over a number of lines at a
> single move of the mouse wheel.

Which desktop environment are you using?
Comment 11 3191602956 2017-05-04 03:44:18 UTC
Apologies for a delay. I use Win 10, and the libreoffice Version is 5.3.2.2.
Comment 12 3191602956 2017-05-04 03:45:43 UTC Comment hidden (obsolete)
Comment 13 Xisco Faulí 2017-05-04 08:53:31 UTC
Hi,
is this issue still reproducible ?
I can't reproduce it in

Version: 5.4.0.0.alpha1+
Build ID: f12096272e684ddcd8ffa4e34dcb0a680cc594c2
CPU threads: 4; OS: Linux 4.8; UI render: default; VCL: gtk2; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 14 3191602956 2017-05-04 11:46:17 UTC
(In reply to Xisco Faulí from comment #13)
> Hi,
> is this issue still reproducible ?
> I can't reproduce it in
> 
> Version: 5.4.0.0.alpha1+
> Build ID: f12096272e684ddcd8ffa4e34dcb0a680cc594c2
> CPU threads: 4; OS: Linux 4.8; UI render: default; VCL: gtk2; 
> Locale: ca-ES (ca_ES.UTF-8); Calc: group

Yes, very much so. I'd attach a video, but they all come over 5MB, no matter how low I set the resolution.
Comment 15 Buovjaga 2017-05-04 15:05:40 UTC
(In reply to 3191602956 from comment #14)
> Yes, very much so. I'd attach a video, but they all come over 5MB, no matter
> how low I set the resolution.

Our upload limit is 10MB.
Comment 16 Caolán McNamara 2017-07-28 12:02:02 UTC
This issue was logged as a specifically gtk3 related one, comments #9 to #15 are related to windows 10, so won't be addressed here

I can't reproduce any laggy scrolling in 5.3 anymore, I feel this may have been addressed by 
https://cgit.freedesktop.org/libreoffice/core/commit/?id=7f60978b2ccd0e17816b78bde60c6e0e60a9d52e

and

https://cgit.freedesktop.org/libreoffice/core/commit/?id=b53c84af0a34aa9193b0e35363ca2ebe00c3e32c