Download it now!
Bug 103980 - FILEOPEN: DOCX: Spacing between bullets is incorrect
Summary: FILEOPEN: DOCX: Spacing between bullets is incorrect
Status: RESOLVED DUPLICATE of bug 103961
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.2.3.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:docx, regression
Depends on:
Blocks: DOCX-Bullet-Number-Outline-Lists
  Show dependency treegraph
 
Reported: 2016-11-17 11:10 UTC by Xisco Faulí
Modified: 2018-07-24 08:11 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
comparison (2.28 MB, application/pdf)
2016-11-17 11:12 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2016-11-17 11:10:54 UTC
1. Open attachment 91044 [details]

Observed behaviour: Spacing between bullets is incorrect

Reproduced in 

Version: 5.3.0.0.alpha1+
Build ID: 757a60d01dd152aadab2ba3c8224252481ce8a88
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; Layout
Engine: new; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

but not in

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e
Comment 1 Xisco Faulí 2016-11-17 11:12:41 UTC
Created attachment 128811 [details]
comparison
Comment 2 A (Andy) 2016-11-19 08:10:42 UTC
Reproducible also with LO 5.2.3.3 (Win 8.1).

The line spacing between the bullets is incorrect (it is increased) in LO compared to Word.
Comment 3 raal 2016-11-23 22:20:59 UTC
This seems to have begun at the below commit.
Adding Cc: to Miklos Vajna ; Could you possibly take a look at this one? Thanks

author	Miklos Vajna <vmiklos@collabora.co.uk>	2016-03-29 12:03:00 (GMT)
committer	Miklos Vajna <vmiklos@collabora.co.uk>	2016-03-29 13:26:57 (GMT)
commit	eae2331f83bd58bacccd898d60f6c5f54856c036 (patch)
tree	f73e187dfc7d8673b15a0bee475ccdb98270a85c
parent	dde79dd5044f6b5d6d9973f8f335956bfcb6fb4c (diff)
tdf#98882 DOCX import: set default para properties on the Standard para style
That's what the DOC import does, and that's the reason e.g. the strange
unwanted crop of the as-char anchored picture doesn't happen there.

This also needs the "reset all existing style properties back to
default" logic to be adapted: the Standard style has to be reset before
the default are set, and later it should be left alone, otherwise the
defaults are lost.

5c14252fb0be0d2e8f8afdfc2e63525a947adce6 is the first bad commit
commit 5c14252fb0be0d2e8f8afdfc2e63525a947adce6
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Sat Apr 2 17:02:56 2016 -0700

    source sha:eae2331f83bd58bacccd898d60f6c5f54856c036
 git bisect log
# bad: [6380ca07b05f68dedcaa379302cfe1fa478571c4] source sha:60b74fe1775e647545d2da1fcc58a4c63ec18aa5
# good: [1f670510f08cb800cbae2a1dd6ea70d3542e4721] source sha:49c2b9808df8a6b197dec666dfc0cda6321a4306
git bisect start 'origin/master' 'oldest'
# good: [38f37b8ec1a2d199bb957cfd2581df7d1b273b74] source sha:c0da1080b61a1d51654fc34fdaeba373226065ff
git bisect good 38f37b8ec1a2d199bb957cfd2581df7d1b273b74
# bad: [11ae494d8c566f23e0ef84ba0cc25fb1388b67f7] source sha:470cfa9860232ab70e017e6084d80f80d469555c
git bisect bad 11ae494d8c566f23e0ef84ba0cc25fb1388b67f7
# good: [d247d25062e6cc4afccdc3c4be84a2b98523b36a] source sha:150c1dcab007dd8acc1551791f42eef692f9e531
git bisect good d247d25062e6cc4afccdc3c4be84a2b98523b36a
# bad: [812f064e57b17d51c4e0804fb39e13f0e0661ff2] source sha:8d123bf1491bcc7415f4dde3ddd397a11146bb38
git bisect bad 812f064e57b17d51c4e0804fb39e13f0e0661ff2
# good: [c649da763f4116e21b0cef91c706ea7bb73c25bc] source sha:402572e25c0c9eb1f01c928f2ae422ab62a55ba1
git bisect good c649da763f4116e21b0cef91c706ea7bb73c25bc
# good: [d16c94f250b69c07168c9c677ae39f5b4f7044c1] source sha:82510829d5be4321166ae80679b43b376f41ae9e
git bisect good d16c94f250b69c07168c9c677ae39f5b4f7044c1
# bad: [3f29a604df78a6d7b5a0fd4f0794b196431f0a34] source sha:a9a9f694089505c5fbbf5e099d5e185e1a46ab29
git bisect bad 3f29a604df78a6d7b5a0fd4f0794b196431f0a34
# good: [e892c24b9cca10f4d3f4b5c2ca30d5744537a21a] source sha:ed7ad21acf35ffdad8656b25e664131bcf38b331
git bisect good e892c24b9cca10f4d3f4b5c2ca30d5744537a21a
# good: [25132308ede791e4e967b1429f8602ed6fcfb5e7] source sha:d739811038c54081ea4039a939af8f320b31378b
git bisect good 25132308ede791e4e967b1429f8602ed6fcfb5e7
# bad: [5c14252fb0be0d2e8f8afdfc2e63525a947adce6] source sha:eae2331f83bd58bacccd898d60f6c5f54856c036
git bisect bad 5c14252fb0be0d2e8f8afdfc2e63525a947adce6
# good: [13d81a7d0fd3bf11073832a936b4e993c86b05f8] source sha:0f2e6f1fbb42fe33bee3ffd5b5200b17be3382d9
git bisect good 13d81a7d0fd3bf11073832a936b4e993c86b05f8
# good: [1a12505420c113393b0bef425c930ce5a81db8e2] source sha:a91272a6a423e911b832b2f103a77521b4106ed1
git bisect good 1a12505420c113393b0bef425c930ce5a81db8e2
# good: [0ab0b76861fe450ae3ae246d85ff56425cf94384] source sha:dde79dd5044f6b5d6d9973f8f335956bfcb6fb4c
git bisect good 0ab0b76861fe450ae3ae246d85ff56425cf94384
# first bad commit: [5c14252fb0be0d2e8f8afdfc2e63525a947adce6] source sha:eae2331f83bd58bacccd898d60f6c5f54856c036
Comment 4 Xisco Faulí 2016-12-12 19:52:17 UTC
*** Bug 104348 has been marked as a duplicate of this bug. ***
Comment 5 Justin L 2018-07-24 08:11:06 UTC
Fixed in LO 6.2. No plans to backport this one.

*** This bug has been marked as a duplicate of bug 103961 ***