Bug 103981 - FILEOPEN: DOCX: Text label orientation not imported
Summary: FILEOPEN: DOCX: Text label orientation not imported
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha0+ Master
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:docx, regression
Depends on:
Blocks: DOCX
  Show dependency treegraph
 
Reported: 2016-11-17 11:26 UTC by Xisco Faulí
Modified: 2017-07-24 08:10 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2016-11-17 11:26:32 UTC
1. Open attachment 82546 [details]

Observed behaviour: X labels in char 1 and 3 are horizontal
Expected behaviour: X labels in char 1 and 3 should be rotated 45 degrees

Reproduced in 

Version: 5.3.0.0.alpha1+
Build ID: 757a60d01dd152aadab2ba3c8224252481ce8a88
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; Layout
Engine: new; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

but not in

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e
Comment 1 Xisco Faulí 2016-11-17 11:28:13 UTC
Regression introduced by:

author	Kohei Yoshida <kohei.yoshida@collabora.com>	2014-06-12 15:24:30 (GMT)
committer	Kohei Yoshida <kohei.yoshida@collabora.com>	2014-06-12 15:27:19 (GMT)
commit	a2a1a59a448420a858724371c4a339f75ebe8c1e (patch)
tree	712007fb53468d43a1010e42c71cfd7eaf5976dc
parent	10f8d24540a4145af3ec629f7eb724849ca53d22 (diff)
fdo#77506: More reliable way to determine label strings.

Not beautiful, but doable.

Adding Cc: to Kohei Yoshida
Comment 2 Dennis Francis 2017-07-24 05:51:29 UTC
(In reply to Xisco Faulí from comment #0)
> 1. Open attachment 82546 [details]
> 
> Observed behaviour: X labels in char 1 and 3 are horizontal
> Expected behaviour: X labels in char 1 and 3 should be rotated 45 degrees
> 
> Reproduced in 
> 
> Version: 5.3.0.0.alpha1+
> Build ID: 757a60d01dd152aadab2ba3c8224252481ce8a88
> CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; Layout
> Engine: new; 
> Locale: ca-ES (ca_ES.UTF-8); Calc: group
> 
> but not in
> 
> Version: 4.3.0.0.alpha1+
> Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e

Could you please check this in latest master ? seems for charts 1 & 3 the xlabels are now showing as rotated by 45 degrees.
Comment 3 Xisco Faulí 2017-07-24 08:10:40 UTC
Hello Dennis,

it seems the problem is no longer reproducible in 

Version: 6.0.0.0.alpha0+
Build ID: bde72cdae1e7e001d5089c5284672c976b8e43df
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

Thanks for checking.
Closing as RESOLVED WORKSFORME