Bug Hunting Session
Bug 104000 - Writer media scan produces scrambled image
Summary: Writer media scan produces scrambled image
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.2.2.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsDevAdvice
Depends on:
Blocks: Scanning
  Show dependency treegraph
 
Reported: 2016-11-18 01:45 UTC by Joseph Conner
Modified: 2018-11-28 22:30 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Simple Scan.pdf (583.10 KB, application/pdf)
2016-11-18 01:45 UTC, Joseph Conner
Details
LO Scan.pdf (1.71 KB, application/pdf)
2016-11-18 01:46 UTC, Joseph Conner
Details
LibreOffice 5.2.3.3 Scan (1.78 KB, application/pdf)
2016-11-23 05:55 UTC, Joseph Conner
Details
LO 5.3.0 Beta1 scan (1.73 KB, application/pdf)
2016-12-03 05:13 UTC, Joseph Conner
Details
600DPI Scan (12.97 KB, application/vnd.oasis.opendocument.text)
2016-12-04 21:25 UTC, Joseph Conner
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Joseph Conner 2016-11-18 01:45:31 UTC
Created attachment 128834 [details]
Simple Scan.pdf

In writer Insert -> media -> scan imports a scrambled image. I attach the image generated by Simple Scan, and the same image generated in LibreOffice 5.2.2.2 exported to .pdf. Both scans use the same source document to be scanned.file:///home/joe/Desktop/LO_Scan.pdf
file:///home/joe/Desktop/Simple%20Scan.pdf
Comment 1 Joseph Conner 2016-11-18 01:46:44 UTC
Created attachment 128835 [details]
LO Scan.pdf
Comment 2 Joseph Conner 2016-11-19 05:54:46 UTC
I am running Ubuntu 16.10 64-bit.
Comment 3 Joseph Conner 2016-11-23 05:55:30 UTC
Created attachment 128952 [details]
LibreOffice 5.2.3.3 Scan

I upgraded to LibreOffice 5.2.3.3 and the problem still persists.
Comment 5 Joseph Conner 2016-12-03 02:32:43 UTC
I attempted to install a fresh master build (5.4.0) but I was unsuccessful. Probably because I totally do not understand how to do it. I will replace my LO 5.2.3.3 with 5.3.0 Release Candidate and see if the phenomena persists.
Comment 6 Joseph Conner 2016-12-03 05:13:49 UTC
Created attachment 129272 [details]
LO 5.3.0 Beta1 scan
Comment 7 Aron Budea 2016-12-04 09:51:28 UTC
I tried with an Epson Perfection 1670 in 5.3.0.0beta1 / Ubuntu 16.04, and could scan normally.

Actually, Insert -> Media -> Scan -> Request... didn't work (didn't do anything... that could be a bug), so I used Select Source..., didn't change anything there, scanned and the image appeared correctly. Are there any particular settings you were using?
Comment 8 Joseph Conner 2016-12-04 15:04:53 UTC
I reverted to LO 5.2.3.3 because I was having too many issues with 5.3.0. My experience parallels Aron's in that Insert -> Media -> Scan -> Request... didn't work (didn't do anything... ). Once I had used select source it scanned, but the image was still scrambled. I see no point in uploading another scrambled image, similar to the ones already submitted. Since I use Ubuntu 16.10 64bit maybe there is some issue connecting LO with 16.10, but the fact that Simple Scan has no trouble scanning makes me think it is a LibreOffice issue.
Comment 9 Joseph Conner 2016-12-04 15:15:10 UTC
I varied the DPI settings in the select source and then rescanned. The scrambled image varied with each different DPI but none were good.
Comment 10 Aron Budea 2016-12-04 19:28:13 UTC
Joseph, what's the manufacturer and model of your scanner?
Could you upload a Writer document that has a scrambled scanned image? Not sure if it'll help much, but it's easier to check the image file itself there than in a processed PDF.
Comment 11 Joseph Conner 2016-12-04 21:25:24 UTC
Created attachment 129306 [details]
600DPI Scan

Different DPI settings produce different scrambled images.
Comment 12 Joseph Conner 2016-12-04 21:28:55 UTC
The computer is fairly genetic PC with a gigabyte motherboard and 16gig ram.
The scanner is a HP Officejet 6700 Premium. It is a combination flatbed, printer, copier, and FAX. It connects to the computer via a usb cable.
Comment 13 Joseph Conner 2016-12-04 21:46:40 UTC
I solved the problem. The scan settings under select source were defaulting to lineart. This setting does not show up in the initial select source window. By opening up scan mode sub choices of mode and source appear. Source defaults to flatbed, which is fine, but mode defaults to lineart which causes the problem. Switching the mode to grey or color allows the scan to not be scrambled.

I suggest making these settings visible from the start select source window.
Comment 14 Joseph Conner 2016-12-05 02:31:35 UTC
Better yet, have some obvious way to set the defaults.
Comment 15 Justin L 2017-05-16 12:15:42 UTC
Unable to confirm.  All of my environments (bibisect, compiled LO, OS-installed LO) all default to the gray mode of scanning.

Likely it was a user-preference setting saved in your user profile. Deleting the profile and starting from a fresh one likely would have solved the issue.
Comment 16 Joseph Conner 2017-05-16 17:53:24 UTC
(In reply to Justin L from comment #15)
> Unable to confirm.  All of my environments (bibisect, compiled LO,
> OS-installed LO) all default to the gray mode of scanning.
> 
> Likely it was a user-preference setting saved in your user profile. Deleting
> the profile and starting from a fresh one likely would have solved the issue.

I have totally removed the libreoffice, including profile. Then I downloaded and installed LO 5.3.3.2 and updated the operating system to Ubuntu 17.04.  There is no change in the behaviour. The scanner software still defaults to lineart. There seems to be no way to make it default to anything else. Each use of the scan this setting must be reset.
Comment 17 Jean-Baptiste Faure 2017-09-09 18:36:17 UTC
(In reply to Joseph Conner from comment #16)
> [...]
> I have totally removed the libreoffice, including profile. Then I downloaded
> and installed LO 5.3.3.2 and updated the operating system to Ubuntu 17.04. 
> There is no change in the behaviour. The scanner software still defaults to
> lineart. There seems to be no way to make it default to anything else. Each
> use of the scan this setting must be reset.

If you scan without LibreOffice are you able to change the default config and reuse this default when you scan from LibreOffice?

Set status to NEEDINFO, please set it back to UNCONFIRMED once requested
informations are provided.

Best regards. JBF
Comment 18 Joseph Conner 2017-09-15 22:38:38 UTC
I have XSane and Simple scan installed. Neither of these provide me with the option to set lineart or grey as default. Also, neither of these present the problem.
Comment 19 Xisco Faulí 2018-11-26 19:10:31 UTC
(In reply to Joseph Conner from comment #18)
> I have XSane and Simple scan installed. Neither of these provide me with the
> option to set lineart or grey as default. Also, neither of these present the
> problem.

Could you please try to reproduce it with the latest version of LibreOffice
from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the bug is still present in the latest version.
Comment 20 Joseph Conner 2018-11-28 22:27:43 UTC
I am now using Ubuntu 18.10, and LibreOffice Version: 6.1.1.2. Also I have changed to the scanner in HP Photosmart 5200 series. I no longer am able to reproduce the problem. The scanner settings now persist upon relaunch. I have tried both simple scan and xSane, both are working as expected.
Comment 21 Xisco Faulí 2018-11-28 22:30:46 UTC
Thanks for retesting with the latest version.
Setting to RESOLVED WORKSFORME as the commit fixing this issue hasn't been identified.