Bug 104017 - FILESAVE: DOC: New rows are displayed on table after RT
Summary: FILESAVE: DOC: New rows are displayed on table after RT
Status: RESOLVED DUPLICATE of bug 108233
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha0+ Master
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.4.0 target:6.3.4 target:7.0....
Keywords: bibisected, bisected, filter:doc
Depends on:
Blocks: DOC-Tables
  Show dependency treegraph
 
Reported: 2016-11-18 18:59 UTC by Xisco Faulí
Modified: 2020-06-18 07:30 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
sample2 (36.50 KB, application/msword)
2016-12-15 20:04 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2016-11-18 18:59:26 UTC
Steps:
1. Open attachment 87420 [details]
2. Save it as a new .DOC file
2. open the new file

Observed behaviour: new rows are displayed on the table

Reproduced in 

Version: 5.3.0.0.alpha1+
Build ID: 757a60d01dd152aadab2ba3c8224252481ce8a88
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; Layout
Engine: new; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

but not in

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e
Comment 1 Xisco Faulí 2016-11-18 19:01:11 UTC
Regression introduced by:

author	Miklos Vajna <vmiklos@collabora.co.uk>	2014-07-28 14:58:38 (GMT)
committer	Miklos Vajna <vmiklos@collabora.co.uk>	2014-07-28 15:06:44 (GMT)
commit	7146d8bcd96f844dc0239a5b29a6b36c3cb5a2cc (patch)
tree	e152d7c7f09491146e4be0a5b671a642ff01cee3
parent	0f21977d1d17170913d49987f070b9581395d7dd (diff)

MSWordExportBase::OutputSectionBreaks: avoid fake section breaks
Regression from ee9f23bb94b4c2c8c4db6466ecca272a092e9492 (docx export:
invalid sectPr added at the beginning of the doc, 2013-01-10), the
problem was that we even tried to generate section breaks at places
where the two page styles are in practice the same.

Adding Cc: to Miklos Vajna
Comment 2 Xisco Faulí 2016-12-15 20:04:06 UTC
Created attachment 129676 [details]
sample2

another file affected by the same commit
Comment 3 Telesto 2018-01-07 19:54:40 UTC
Adding bug 93366 as See also. It's also a regression from ee9f23bb94b4c2c8c4db6466ecca272a092e9492
Comment 4 QA Administrators 2019-01-08 03:43:08 UTC Comment hidden (obsolete, spam)
Comment 5 Xisco Faulí 2019-01-28 16:45:08 UTC
Still reproducible in

Version: 6.3.0.0.alpha0+
Build ID: ef28740d0ae036f6fa2e9866cadf335e9f0ad8b9
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Justin, you just closed bug 113849 which was caused by ee9f23bb94b4c2c8c4db6466ecca272a092e9492, which is also mentioned in 7146d8bcd96f844dc0239a5b29a6b36c3cb5a2cc

I thought you might be interested in this issue...
Comment 6 Commit Notification 2019-10-29 07:43:04 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/5d1709a7c4184eb31cfc4c2d3acadff3a4a68189

tdf#104017 DOC export: be less aggressive with merging page styles

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2019-10-30 10:20:44 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/c74c72464573f519e08f1e7826bced247b329d29

tdf#104017 DOC export: be less aggressive with merging page styles

It will be available in 6.3.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Xisco Faulí 2019-10-31 11:54:31 UTC
Verified in

Version: 6.4.0.0.alpha1+
Build ID: 2d0a4182712673d8f7a5abe919cd2a1d5ece4a77
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Miklos, thanks for fixing this issue!!
Comment 9 Commit Notification 2020-05-25 13:00:12 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/42a37f8ce27ad8fca222f50b712a8fed52dbda95

Revert "tdf#104017 DOC export: be less aggressive with merging page styles"

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2020-05-26 07:10:51 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/70a2071ce91b71326659e645dd97996262ea309a

Revert "tdf#104017 DOC export: be less aggressive with merging page styles"

It will be available in 6.4.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Justin L 2020-05-26 08:38:37 UTC
The fix that was reverted seemed to just be a "this document now works" but not something that actually corrected an underlying problem. Since the fix causes more problems (and this is a table bug - where tables always need special treatment), this patch was reverted to prevent actual regressions like bug 133334. 

This problem of a break missing between tables is more generically defined in bug 48097. A proper fix for that should also fix this case.

Removing the tag "regression" from this bug since it just "happened to work" in this particular case.

*** This bug has been marked as a duplicate of bug 48097 ***
Comment 12 Justin L 2020-06-18 07:30:17 UTC
I'm going to mark this as a duplicate of bug 108233, since that report is very clear, and indicates that it is POSSIBLE for ODF to handle per-row breaks. Only the UI needs to be extended to support that.

*** This bug has been marked as a duplicate of bug 108233 ***