Download it now!
Bug 104045 - Export pdf - Vertical borders in tables disappear - for certain border styles
Summary: Export pdf - Vertical borders in tables disappear - for certain border styles
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.2.3.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:pdf
Depends on:
Blocks: PDF-Export
  Show dependency treegraph
 
Reported: 2016-11-20 01:56 UTC by Grobe
Modified: 2018-12-08 16:23 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
sample documents (113.53 KB, application/x-7z-compressed)
2016-11-20 02:13 UTC, Grobe
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Grobe 2016-11-20 01:56:33 UTC
Description:
One specific type of dotted lines seems to not appear in exported PDF documents. It's gray dotted lines. It is ONLY vertical lines that dissapear, not horisontal ones - even if the line formatting is equal.

I'll add some sample files to show what works and what do not works, both odf and pdf versions:
table_514 - Sample document made in LibO 5.1.4 (oly one made in older version). Status: FAIL.
table_523 - Same document, saved in version 5.2.3. status: FAIL.
< Noumerous different documents between - won't comment all those. Status: they all fail >
table_523_vertical-only_3 - Same, but another style for vertical lines applied. Status: Success.

Steps to Reproduce:
1.Make new document or use an existing one (haven't tried old documents from earlier versions of LibO)
2.Make a table that have both inner and outer borders. The inner vertical borders must be colored gray and dotted. There might be several combinations of line type and colors that also is affected.
3.Export to PDF file - the vertical inner border won't be visible in the PDF file.

Actual Results:  
the vertical inner border in tables won't be visible in the PDF file.

Expected Results:
All table borders lines should look excactly as in LibO Writer.


Reproducible: Always

User Profile Reset: No. I did install version 5.2.3.3 over an older version of LibO (5.1.4) - same results. I have also tried the same on another computer with 32 bit version of LibO (an even older version and I cannot remember what version it was).
That lead me to beleive the issue is not related to user profile.

Additional Info:
I saw a similar issue as long as a year ago on another computer. Sadly I didn't realized that it was a bug - I thaught I had forgot something before printing (I saw it at a time when I was far away from the computer using to make the table).
That was at least a half year ago, maybe longer. Same issue.

I have not installed a printer at home, so I can't tell if same problem will apply if I print directly from Writer. Also print to XPS doesn't provide an actual file for some reason.


User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0
Comment 1 Grobe 2016-11-20 02:13:38 UTC
Created attachment 128880 [details]
sample documents

One packed 7z file consisting of 6 pair of odt/pfd files. Total of 12 files.
Each odt file have an exported PDF file with matching name.

In every file, I've added information on current version of Libre Office used.
Comment 2 Xisco Faulí 2016-11-20 18:06:34 UTC
Confirmed in

Version: 5.3.0.0.alpha1+
Build ID: 9745d29227e471ce40e9992fefd92e10a48696fb
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; Layout Engine: new; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 3 Telesto 2017-12-07 19:14:58 UTC
No repro with
Version: 6.1.0.0.alpha0+
Build ID: cc1db6f2b0ebe05ae807628778835b62df00eca2
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-12-02_23:45:34
Locale: nl-NL (nl_NL); Calc: CL

I tested:
table_514
table_523
Comment 4 QA Administrators 2018-12-08 03:47:05 UTC Comment hidden (obsolete)
Comment 5 Roman Kuznetsov 2018-12-08 10:53:29 UTC
(In reply to Telesto from comment #3)
> No repro with
> Version: 6.1.0.0.alpha0+
> Build ID: cc1db6f2b0ebe05ae807628778835b62df00eca2
> CPU threads: 4; OS: Windows 6.3; UI render: default; 
> TinderBox: Win-x86@42, Branch:master, Time: 2017-12-02_23:45:34
> Locale: nl-NL (nl_NL); Calc: CL
> 
> I tested:
> table_514
> table_523

No repro in

Версия: 6.1.3.1 (x64)
ID сборки: a9670562c26181ec3afbe381c9ff499ae88c98b7
Потоков ЦП: 4; ОС:Windows 10.0; Отрисовка ИП: GL; 
Локаль: ru-RU (ru_RU); Calc: threaded

Status->WFM