Bug Hunting Session
Bug 104077 - FILEOPEN: RTF: Text imported with incorrect color
Summary: FILEOPEN: RTF: Text imported with incorrect color
Status: RESOLVED DUPLICATE of bug 109790
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.0.0.alpha0+ Master
Hardware: All All
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:rtf, regression
Depends on:
Blocks: RTF
  Show dependency treegraph
 
Reported: 2016-11-21 09:53 UTC by Xisco Faulí
Modified: 2017-09-05 15:28 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
sample (526.03 KB, application/rtf)
2016-11-21 09:53 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2016-11-21 09:53:57 UTC
Created attachment 128913 [details]
sample

1. Open attached file

Observed behaviour: Text 'Feather token, anchor' in table is red

Reproduced in 

Version: 5.3.0.0.alpha1+
Build ID: 757a60d01dd152aadab2ba3c8224252481ce8a88
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; Layout
Engine: new; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

but not in

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e
Comment 1 Xisco Faulí 2016-11-21 09:55:31 UTC
Regression introduced by:

author	Miklos Vajna <vmiklos@collabora.co.uk>	2015-05-18 05:38:32 (GMT)
committer	Miklos Vajna <vmiklos@collabora.co.uk>	2015-05-18 05:47:20 (GMT)
commit	cbe79789a0fc9b80b2fd14a5abfe0973a2cb69dc (patch)
tree	11b1f41d7a05a6787513b0ef2efb3f2ce9085465
parent	3aebc670e1816a8f4f0759e97d8f39b6aab05044 (diff)

tdf#86814 RTF import: fix sometimes lost bold style
The problem was that commit 76c0d0abc89cd8948706083c2660b71a2dad670c
(RTF import: adapt getProperties() to createStyleProperties(),
2014-09-07) only made the character style sprms/attributes a flat list,
but not the paragraph style ones. Fixing that inconsistency avoids the
tokenizer adding unwanted default sprms, which cause the bold sprms go
away in the bugdoc.

Adding Cc: to Miklos Vajna
Comment 2 Xisco Faulí 2016-12-01 09:41:17 UTC
It seems the same commit affects attachment 70632 [details] and text in second page is black instead of blue
Comment 3 Miklos Vajna 2017-09-05 15:28:48 UTC
Reverse bisect shows this is a duplicate of bug 109790.

*** This bug has been marked as a duplicate of bug 109790 ***