Bug Hunting Session
Bug 104100 - icons missing in the galaxy icon set
Summary: icons missing in the galaxy icon set
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.2.3.3 release
Hardware: All All
: low trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks: Icon-Theme-Galaxy
  Show dependency treegraph
 
Reported: 2016-11-22 05:56 UTC by Philippe Hemmel
Modified: 2018-12-25 14:08 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philippe Hemmel 2016-11-22 05:56:11 UTC
Hello

Some icons are missing in the galaxy icon set in Writer. Instead texts are displayed on the buttons. Version 5.1.5, 5.1.6 and 5.2.3.

Main bar :
- show track changes bar
- data sources (only in small size in version 5.1.5 and 5.1.6, seems ok in 5.2.3, at least on Linux OpenSuse)

Table bar : 
- select cell
- split table
- number format
- unprotect cells

Strangely there is a way to "fix" this bug. For windows :
- in {install dir}\share\config, copy the file images_galaxy.zip to images_galaxy2.zip
- in LO, select the galaxy2 icon set
- it works... I don't know why.
Comment 1 Buovjaga 2016-11-28 20:08:08 UTC
Confirmed.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.4.0.0.alpha0+
Build ID: 368de904974b18dc5a8d237e046c0ed005f7c85d
CPU Threads: 8; OS Version: Linux 4.8; UI Render: default; VCL: kde4; Layout Engine: new; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on November 26th 2016
Comment 2 Philippe Hemmel 2016-12-02 18:33:20 UTC
Unfortunately other icons are missing in the Formatting Chart toolbar : 

- chart area
- chart wall
- data ranges
- titles
- legend
- Z axis

And my way to "fix" the bug doesn't work for these ones.
Comment 3 Yousuf Philips (jay) (retired) 2017-05-26 19:54:58 UTC
Galaxy is no longer being worked on, so it is highly unlikely that icons will be coming for any of these buttons. Previously we used to copy tango icons into Galaxy, but that stopped happening around LO 4.4 or so.

(In reply to Philippe Hemmel from comment #0)
> Main bar :
> - show track changes bar

I only see 'Merge' which doesnt have an icon.

> - data sources (only in small size in version 5.1.5 and 5.1.6, seems ok in
> 5.2.3, at least on Linux OpenSuse)

The following entries in links.txt seem to be messing this up.
cmd/lc_viewdatasourcebrowser.png cmd/lc_dataranges.png
cmd/sc_viewdatasourcebrowser.png cmd/sc_dataranges.png

> Table bar : 
> - select cell
> - split table
> - number format
> - unprotect cells

Small and large icons are missing for all of these and a large icon is missing for Protect Cells.

> Strangely there is a way to "fix" this bug. For windows :
> - in {install dir}\share\config, copy the file images_galaxy.zip to
> images_galaxy2.zip
> - in LO, select the galaxy2 icon set
> - it works... I don't know why.

This is because it is falling back on tango, which has these icons.

@Regina: Is this something you want to take on?
Comment 4 Regina Henschel 2017-05-26 20:12:57 UTC
Yes, I like Galaxy icon-theme. But I will have no time for it in the next two months.
Comment 5 QA Administrators 2018-08-01 02:50:01 UTC Comment hidden (obsolete)
Comment 6 Roman Kuznetsov 2018-12-25 14:08:13 UTC
Galaxy Theme was removed in LO 6.1

Status->WontFix