Download it now!
Bug 104110 - FILEOPEN RTF: The text within a textbox contained in a drawing canvas is invisible
Summary: FILEOPEN RTF: The text within a textbox contained in a drawing canvas is invi...
Status: RESOLVED DUPLICATE of bug 126173
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:rtf, notBibisectable, regression
Depends on:
Blocks: RTF
  Show dependency treegraph
 
Reported: 2016-11-22 13:40 UTC by Telesto
Modified: 2019-07-09 09:16 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file (17.73 KB, text/rtf)
2016-11-22 13:40 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2016-11-22 13:40:14 UTC
Description:
The text within the textbox isn't visible if text is in a drawing canvas 

Steps to Reproduce:
1.Open Example File
2.The textbox contains 'Hello World' 

Actual Results:  
The text 'Hello World' isn't visible

Expected Results:
The text 'Hello World' is visible


Reproducible: Always

User Profile Reset: YES

Additional Info:
Found in:
Version: 5.3.0.0.alpha1+
Build ID: 02ec51c7e0bf9320b32ec73233ecaaf160448776
CPU Threads: 4; OS Version: Windows 6.2; UI Render: GL; Layout Engine: new; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2016-11-20_23:12:18
Locale: nl-NL (nl_NL); Calc: CL

and
Versie: 4.4.6.3 
Build ID: e8938fd3328e95dcf59dd64e7facd2c7d67c704d
Locale: nl_NL


User-Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Comment 1 Telesto 2016-11-22 13:40:32 UTC
Created attachment 128943 [details]
Example file
Comment 2 Xisco Faulí 2016-11-22 15:58:53 UTC
Confirmed in

Version: 5.3.0.0.alpha1+
Build ID: 4ebf1ea7cb66fc3e6b94cd38dd233aaead69f3d5
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; Layout
Engine: new; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

Text 'Hello World' can be seen in

Version: 4.3.0.0.alpha0+
Build ID: 3c0a7cf4f67720f2cca2c4eb543f838d5b644e7f

thus, this is a regression
Comment 3 Xisco Faulí 2017-03-10 14:38:24 UTC
Reproduced in

Version: 4.5.0.0.alpha0+
Build ID: 2851ce5afd0f37764cbbc2c2a9a63c7adc844311
Locale: ca_ES
Comment 4 Aron Budea 2017-04-01 20:27:06 UTC
Similarly to bug 104111, in 4.4.0.3 the text already can't be seen, and in 4.3.0.4 the document gives:
"General Error. General input/output error."
Probably not worth bibisecting.
Comment 5 Aron Budea 2018-05-24 14:20:30 UTC
Build starts crashing from this commit, good until this:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=c6b99eedda03461202f9bf012a422dfd81da72ec
author		sushil_shinde <sushil.shinde@synerzip.com>	2014-02-28 15:33:10 +0530
committer	Miklos Vajna <vmiklos@collabora.co.uk>	2014-03-07 03:19:07 -0600

fdo#75158 : Handled unsupported fields for docx file.

No more crashes since this commit, but the document is already buggy:
https://cgit.freedesktop.org/libreoffice/core/commit/?id=258888bc3f0ba4474ff66d49d698f4551df736eb
author		Caolán McNamara <caolanm@redhat.com>	2014-09-17 16:15:35 +0100
committer	Caolán McNamara <caolanm@redhat.com>	2014-09-17 16:15:56 +0100

don't crash on insertTextPortion returning empty reference

=> notbibisectable
Comment 6 QA Administrators 2019-05-25 02:56:26 UTC Comment hidden (obsolete)
Comment 7 Xisco Faulí 2019-07-09 09:16:26 UTC
Issue fixed by https://cgit.freedesktop.org/libreoffice/core/commit/?id=9a15a75dfa7ab8c5d51c411e0e39d68d22b7587a, closing as a dupe of bug 126173

*** This bug has been marked as a duplicate of bug 126173 ***