Bug Hunting Session
Bug 104147 - Add support for Visio Stencils (.vss/.vssx) and Templates (.vst/vstx).
Summary: Add support for Visio Stencils (.vss/.vssx) and Templates (.vst/vstx).
Status: RESOLVED DUPLICATE of bug 89469
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Gallery
  Show dependency treegraph
 
Reported: 2016-11-24 17:08 UTC by John Smith
Modified: 2016-12-20 20:12 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Visio Stencils and Templates (3.75 MB, application/x-zip)
2016-11-24 17:08 UTC, John Smith
Details
Screenshot of Visio Stencil in Viso (74.32 KB, image/png)
2016-11-24 17:10 UTC, John Smith
Details
Screenshot of Visio Template in Viso (132.01 KB, image/png)
2016-11-24 17:10 UTC, John Smith
Details

Note You need to log in before you can comment on or make changes to this bug.
Description John Smith 2016-11-24 17:08:24 UTC
Created attachment 128990 [details]
Visio Stencils and Templates

Opening 'Visio Stencil' (.vss/.vssx) or 'Visio Template' (.vst/vstx) files in LibreOffice currently display as a blank page. It would be a nice addition if they could be displayed/used the same way as in Visio, and would like to open an enhancement request for that. See the attachments for example screenshots of these files opened in Visio, and actual example Visio files.

A previous bug #58425 has been closed as 'NOTOURBUG', because "Libvisio has API to extract stencils from the vss/vsx and vst/vtx files. However, LibreOffice does not have API to generate galleries on the fly". Therefore, an enhancement request may be more appropriate.
Comment 1 John Smith 2016-11-24 17:10:04 UTC
Created attachment 128991 [details]
Screenshot of Visio Stencil in Viso
Comment 2 John Smith 2016-11-24 17:10:33 UTC
Created attachment 128992 [details]
Screenshot of Visio Template in Viso
Comment 3 Joel Madero 2016-11-25 05:03:44 UTC
Fine enhancement request.

FYI: Enhancements are handled entirely by volunteers. I am simply marking as a valid request - this does not mean it will be implemented (ever). A developer with serious skills and time would have to find this interesting enough to do. It could happen relatively quickly or it could never be implemented.

Thanks for the suggestion.
Comment 4 John Smith 2016-11-25 17:19:04 UTC
Thanks for marking the request as valid. I fully realize that all effort put into open source projects is purely on a volunteer basis, and that this may not ever be implemented at all. I only wanted to mark this as a feature/enhancement that I would personally like to see, given enough interest by volunteer developers of course.
Comment 5 Heiko Tietze 2016-12-18 09:52:06 UTC
Good idea, although I would rather make it an import-to-gallery function.

But please check your uploaded files for being not copyright protected, John. The zipped file contains stencils which may be not based on your own work.

Setting NEEDINFO for that, please change back the NEW eventually.
Comment 6 John Smith 2016-12-18 11:02:11 UTC
Hi,


The Visio material attached to this enhancement request can be freely downloaded here:

Microsoft Office Visio Stencil Containing Shapes for Microsoft Exchange Server 2007

https://www.microsoft.com/en-us/download/details.aspx?id=4290
Comment 7 John Smith 2016-12-20 17:26:54 UTC
Now that the requested information has been given, and it has been shown that the visio material can be freely downloaded from the public microsoft website (see previous reply) without any copyright statement either on the website or in the downloaded file, Im assuming that it is ok to set the status back to 'new' again.
Comment 8 V Stuart Foote 2016-12-20 19:49:23 UTC
close to verbatim dupe of bug 89469, but Fridrich S. explains functional issues with libvisio which has API support but LO has no means to make use of it dynamically, in NOTOURBUG bug 58425

*** This bug has been marked as a duplicate of bug 58425 ***
Comment 9 John Smith 2016-12-20 19:57:29 UTC
(In reply to V Stuart Foote from comment #8)
> close to verbatim dupe of bug 89469, but Fridrich S. explains functional
> issues with libvisio which has API support but LO has no means to make use
> of it dynamically, in NOTOURBUG bug 58425
> 
> *** This bug has been marked as a duplicate of bug 58425 ***

I fully realize that there is not currently API support. This ENHANCEMENT request is about adding that API support.
Comment 10 V Stuart Foote 2016-12-20 20:01:26 UTC

*** This bug has been marked as a duplicate of bug 58425 ***
Comment 11 John Smith 2016-12-20 20:05:13 UTC
(In reply to V Stuart Foote from comment #10)
> 
> *** This bug has been marked as a duplicate of bug 58425 ***
So, there is no way to ask for an enhancement of api or otherwise ask for a feature that currently is not in libreoffice. got it. thanks.
Comment 12 V Stuart Foote 2016-12-20 20:12:42 UTC
Rather than reopen the bug 58425, that was filed as a bug not an enhancment. Bug 89469 should probably not have been closed as a dupe.

Reopening that.

*** This bug has been marked as a duplicate of bug 89469 ***