Bug Hunting Session
Bug 104158 - Crash upon opening Table -> Number Format... in Writer
Summary: Crash upon opening Table -> Number Format... in Writer
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.0.0.beta1
Hardware: All All
: high critical
Assignee: Not Assigned
URL:
Whiteboard: target:5.4.0 target:5.3.0.1
Keywords: notBibisectable, regression
Depends on:
Blocks: Number-Format
  Show dependency treegraph
 
Reported: 2016-11-25 11:02 UTC by Aron Budea
Modified: 2017-05-02 23:35 UTC (History)
3 users (show)

See Also:
Crash report or crash signature: ["SwTableShell::Execute(SfxRequest &)"]


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2016-11-25 11:02:15 UTC
1. Start a new document in Writer.
2. Add a table.
3. Open menu Table -> Number Format...

=> crash.

Used 5.3.0.0beta1 / Windows 7.
Crash report: http://crashreport.libreoffice.org/stats/crash_details/9918fb3a-6981-466a-a79b-d3347170df38

Kudos to Christian for finding the bug.
Comment 2 Christian Lohmaier 2016-11-25 11:13:23 UTC
confirming (with beta1 on linux, 64bit)
Comment 3 Xisco Faulí 2016-11-25 11:47:47 UTC
Adding CC: to Noel Grandin as eca5ea9f79181d45cd7fbabe2313617d3025818a looks like a good candidate of introducing this issue. I can't bisect it completely because that commit introduced a crash when inserting a table. Then the introducing table crash was fixed by 117fc49c979d65e5479635eab3ce10d74d076679 and at that point the crash in Number Format was already present
Comment 4 Commit Notification 2016-11-25 17:06:35 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=94ea966354609f8030872f1520ffbf910a9d28b4

tdf#104158 - Crash upon opening Table -> Number Format... in Writer

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2016-11-26 05:20:52 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1866cd8654496fd8052409b1f36d018affe3eb4b&h=libreoffice-5-3

tdf#104158 - Crash upon opening Table -> Number Format... in Writer

It will be available in 5.3.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Aron Budea 2016-12-05 21:22:32 UTC
No crash anymore (5.4 daily build 2016-12-02_00:57:58).
Noel, this can be closed, right?
Comment 7 Commit Notification 2017-01-14 09:31:49 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5930cf87454940a0015e9e18f154759163caf929

tdf#104158: Add uitest

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.