Bug Hunting Session
Bug 104192 - Last save location is not remembered across documents/launches on Fedora 25+GNOME 3.22
Summary: Last save location is not remembered across documents/launches on Fedora 25+G...
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-11-26 21:36 UTC by Nate Graham
Modified: 2018-08-20 11:36 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nate Graham 2016-11-26 21:36:40 UTC
Description:
On Fedora 25+GNOME 3.22, the last save location is not remembered across documents/launches.

Steps to Reproduce:
1. Open any LibreOffice app.
2. Make a document, and save it to some deeply-nested location.
3. Make another document, and do the same thing again.

Actual Results:  
The save panel shows the default location (~/Documents), and you need to manually navigate to the desired location.


Expected Results:
When you save the second document, the save panel displays the location where you saved the previous one.


Reproducible: Always

User Profile Reset: Yes.

Additional Info:
This happens with both the system save/load panels as well as the LibreOffice-specific ones.


User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/54.0.2840.90 Safari/537.36
Comment 1 Thomas Hackert 2016-11-27 16:50:58 UTC
Hello Nate, *,
thank you very much for reporting this bug :) I can confirm it with

OS: Debian Testing AMD64
LO: Version: 5.2.3.3
Build-ID: d54a8868f08a7b39642414cf2c8ef2f228f780cf
CPU-Threads: 4; BS-Version: Linux 4.5; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE.UTF-8); Calc: group

back to

OOo: OOO320m12 (Build:9483)
(parallel installed following the instructions from https://wiki.documentfoundation.org/Installing_in_parallel/Linux)

Are you sure, that this has worked in the past? But as I can confirm it, I will change the status to "NEW" and version to "Inherited from OOo".
HTH
Thomas.
Comment 2 Nate Graham 2016-11-27 17:04:25 UTC
I don't know if it ever worked in the past. I can confirm that the problem is seen in the Mac version, too (5.2.2.2).

However, the accepted answer to this question implies that at some point in the past this did work: https://ask.libreoffice.org/en/question/37405/make-libreoffice-remember-last-default-location/

But perhaps that person was mistaken.
Comment 3 Nate Graham 2017-06-28 23:14:49 UTC
This may be an artifact of the GTK file pickers (or the way they're invoked), since I just noticed that the correct behavior is seen when LibreOffice is run in a KDE environment where it uses the QT file pickers instead.
Comment 4 Nate Graham 2017-06-28 23:17:20 UTC
Please ignore that comment. In a KDE environment, the correct behavior is seen with the *open* dialog, but not the *save* dialog. The original bug is still seen in both cases.
Comment 5 QA Administrators 2018-06-29 02:45:46 UTC Comment hidden (obsolete)
Comment 6 Nate Graham 2018-06-29 13:14:52 UTC
Still present in 6.0.3.2

Version: 6.0.3.2
Build ID: 1:6.0.3-0ubuntu1
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: kde4; 
Locale: en-US (en_US.UTF-8); Calc: group
Comment 7 Nate Graham 2018-08-20 11:36:49 UTC
Seems to be an upstream bug. We've found a fix in KDE Plasma: https://phabricator.kde.org/D14437

Probably GTK need a similar change.