Download it now!
Bug 104220 - FORMATTING: Style (file from version before 3.6 or before) now shows spacing despite having no border lines (Workaround: comment#3)
Summary: FORMATTING: Style (file from version before 3.6 or before) now shows spacing ...
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha1+
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2016-11-28 11:25 UTC by Cor Nouws
Modified: 2016-11-28 15:42 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
test file from older version, having paragraph with background color (11.77 KB, application/vnd.oasis.opendocument.text)
2016-11-28 11:27 UTC, Cor Nouws
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Cor Nouws 2016-11-28 11:25:54 UTC
File from older version. 
Heading 2 has background color set
Open in 5.2.3
  >  There is no spacing
Open in 5.3.0 daily master
  >  There is spacing

Obviously this causes all kind of wrapping issues.
And I've seen no option yet to reset the spacing.

A file created in 5.3. master doesn't have the issue.

Will add test file.
Comment 1 Cor Nouws 2016-11-28 11:27:17 UTC
Created attachment 129069 [details]
test file from older version, having paragraph with background color
Comment 2 Xisco Faulí 2016-11-28 12:25:00 UTC
Regression introduced by:

author	Justin Luth <justin_luth@sil.org>	2016-10-31 08:59:09 (GMT)
committer	Miklos Vajna <vmiklos@collabora.co.uk>	2016-11-04 09:20:47 (GMT)
commit	9130627e21dd7c52c5eee1acc4b71f86eb9f3118 (patch)
tree	12faff6c8dee6626ee941d27e4da9016326ad7c5
parent	c1ea561f6a01044357052789bbc6c8ec52061d41 (diff)

tdf#41542 globally allow padding without borders: layout
Styles with borders do not have a requirement for visible borders
in order to apply padding in the ODF specs. This was only an
implementation design, so remove that layout restriction.
So, padding will be allowed now for any border (not just textframes/cells)
and it will be allowed for any format (not only those marked
with the compatibility setting AllowPaddingWithoutBorders - which
is now redefined to indicate whether the UI allows
creating borderless padding).

The global UI implementation to allow creating these types of documents
will come in 5.4.  Allow the layout already in 5.3 to enhance
compatibility between supported versions.

Adding Cc: to Justin Luth
Comment 3 Justin L 2016-11-28 15:21:35 UTC
Padding *is* defined in the "header 2" style.  Styles.xml contains  fo:padding-left="0.15cm" fo:padding-right="0.4cm" fo:padding-top="0.4cm" fo:padding-bottom="0.199cm" fo:border="none".  So actually not showing the padding was a bug.

So do we consider this a regression that requires handling? The UI option to change the padding comes later in 5.4 (intentionally - see bug 41542). It is currently possible to reset the spacing by adding a border, applying, and then removing it. (OP's test document must have been made in a rather old version, since removing the border resets the spacing values to zero since before LO3.6).
Comment 4 Cor Nouws 2016-11-28 15:40:31 UTC
Thanks for explaining

(In reply to Justin L from comment #3)

> So do we consider this a regression that requires handling?
> [...] It is
> currently possible to reset the spacing by adding a border, applying, and
> then removing it.

Since there is a work around and indeed, this comes from a really old version, I'm fine with not spending time on handling this exception.

Now, to inform others about this, I guess a remark on the release notes for 5.3 is best?