Download it now!
Bug 104235 - Generic X icon shown in KDE Plasma taskbar upon launching to Start center
Summary: Generic X icon shown in KDE Plasma taskbar upon launching to Start center
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.3.0.0.beta1
Hardware: x86-64 (AMD64) Linux (All)
: low minor
Assignee: Michael Weghorn
URL:
Whiteboard: target:6.3.0 target:6.2.3
Keywords:
: 124506 (view as bug list)
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2016-11-28 19:24 UTC by JPJ
Modified: 2019-04-03 14:55 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
overlapping toolbars screenshot (38.92 KB, image/png)
2016-11-28 19:26 UTC, JPJ
Details

Note You need to log in before you can comment on or make changes to this bug.
Description JPJ 2016-11-28 19:24:59 UTC
Description:
Version: 5.2.3.3
Build ID: d54a8868f08a7b39642414cf2c8ef2f228f780cf
CPU Threads: 4; OS Version: Linux 4.4; UI Render: default;
Locale: en-US (en_US.UTF-8); Calc: group

OS: KDE Neon User Edition 5.8 = KDE Plasma 5.8.4 on Ubuntu 16.04.1

        With kde integration installed or both kde integration and gnome integration installed, toolbars appear to overlap making it impossible to select a specific tool in many cases.  Also, mousing over a tools in the non-overlapping area results in a strange border drawn around each tool the pointer passed over.

        Without kde integration installed but with gnome integration installed the toolbars look normal.  However, KDE integration is gone and in particular, the gtk file chooser is used.

        Without either kde integration or gnome integration installed, it appears that multiple file menu bars are visible and overlapping.

        I also tried with Version: 5.3.0.0.beta1
Build ID: 690f553ecb3efd19143acbf01f3af4e289e94536
CPU Threads: 4; OS Version: Linux 4.4; UI Render: default; VCL: kde4; Layout Engine: new;
Locale: en-US (en_US.UTF-8); Calc: group

OS: KDE Neon User Edition 5.8 = KDE Plasma 5.8.4 on Ubuntu 16.04.1

       In 5.3 b1 installation of kde integration does not result in overlapping tool bars.  However, installation of kde integration does cause the application specific taskbar icons to disappear and be replaced with a generic X icon for each application.

Steps to Reproduce:
1.  Install kde integration in 5.2.3.3 or 5.3 beta 1
2.  Start LibreOffice

Actual Results:  
In 5.2.3.3 toolbars overlap
In 5.3.0.0.beta1 taskbar icons disappear

Expected Results:
Normal toolbars and taskbar icons with KDE file chooser


Reproducible: Always

User Profile Reset: Yes

Additional Info:


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:43.0) Gecko/20100101 Firefox/43.0 SeaMonkey/2.40
Comment 1 JPJ 2016-11-28 19:26:25 UTC
Created attachment 129090 [details]
overlapping toolbars screenshot
Comment 2 Buovjaga 2016-11-29 19:55:00 UTC
Well, let's keep this for the existing issue, which I confirm (the generic X icon).

Arch Linux 64-bit, KDE Plasma 5
Version: 5.4.0.0.alpha0+
Build ID: 368de904974b18dc5a8d237e046c0ed005f7c85d
CPU Threads: 8; OS Version: Linux 4.8; UI Render: default; VCL: kde4; Layout Engine: new; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on November 26th 2016
Comment 3 QA Administrators 2017-11-30 06:26:55 UTC Comment hidden (obsolete)
Comment 4 Buovjaga 2019-01-01 19:11:41 UTC
The generic X icon is only there, when you launch to the Start center. It goes away after picking an application. Confirmed with the new kde5 backend.

Arch Linux 64-bit
Version: 6.3.0.0.alpha0+
Build ID: 2c7b0030b40de00e8c9ab997bdfe83631861968a
CPU threads: 8; OS: Linux 4.20; UI render: default; VCL: kde5; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded
Built on 1 January 2019
Comment 5 Michael Weghorn 2019-02-27 15:20:40 UTC
Gerrit change: https://gerrit.libreoffice.org/68450
Comment 6 Commit Notification 2019-02-27 19:52:07 UTC
Michael Weghorn committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/cfb2e03a683a8d217b00b8abfd9c55bf61059462%5E%21

tdf#104235: Qt5Frame: Set default icon

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2019-03-12 23:10:26 UTC
Michael Weghorn committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/1ffbe6da60391bcf71c579d4da9543f0b769bfc8%5E%21

tdf#104235: Qt5Frame: Set default icon

It will be available in 6.2.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Michael Weghorn 2019-04-03 14:55:48 UTC
*** Bug 124506 has been marked as a duplicate of this bug. ***