Bug Hunting Session
Bug 104286 - Crash in: SdTransferable::ObjectReleased()
Summary: Crash in: SdTransferable::ObjectReleased()
Status: RESOLVED DUPLICATE of bug 104567
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.2.4.1 rc
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.4.0 target:5.3.0.2 target:5.2.5
Keywords:
Depends on:
Blocks:
 
Reported: 2016-11-30 17:06 UTC by Roman Kuznetsov
Modified: 2017-01-05 20:35 UTC (History)
2 users (show)

See Also:
Crash report or crash signature: ["SdTransferable::ObjectReleased()"]


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Kuznetsov 2016-11-30 17:06:00 UTC
This bug was filed from the crash reporting server and is br-c40243e4-2f7e-44cc-9511-c53f8d158b83.
=========================================

crash LO Impress AFTER his close
Comment 1 Xisco Faulí 2016-12-01 10:39:15 UTC Comment hidden (obsolete)
Comment 2 Roman Kuznetsov 2016-12-01 12:06:27 UTC Comment hidden (obsolete)
Comment 3 ThierryT 2016-12-12 08:35:49 UTC
I have exactly the same problem with version 5.2.4.1 today after using Draw component.

Process :
1. Open and close a draw file.
2. Quit LO
3. Reopening of Libreoffice (Main satrt menu) => I receive the message of a recovery file process without file indication and I had finally the crash report message : crashreport.libreoffice.org/stats/crash_details/681f1509-ba49-4d22-aad1-2870dac0a812
Comment 4 JoNi 2016-12-26 09:25:43 UTC
marking this as duplicate because other has better reproduce steps.

adjusting version, report from comment 0 is from 5.2.4.1

*** This bug has been marked as a duplicate of bug 104567 ***
Comment 5 Commit Notification 2016-12-29 18:24:02 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=db1726216ba200c8a55c23a9d8c2ffd2066263a7

process all outstanding events before shutdown, tdf#104969, tdf#104286, tdf#104399

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2017-01-05 19:39:43 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=cdd309c23de58af306450edfac5d3e74e5c2a913&h=libreoffice-5-3

process all outstanding events before shutdown, tdf#104969, tdf#104286, tdf#104399

It will be available in 5.3.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2017-01-05 20:35:43 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f9c3998c2260995cccce060d1226b47ac2dc8c2d&h=libreoffice-5-2

process all outstanding events before shutdown, tdf#104969, tdf#104286, tdf#104399

It will be available in 5.2.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.