Download it now!
Bug 104289 - FILEOPEN: XSLX - Arrow shapes imported with incorrect rotation and dimension
Summary: FILEOPEN: XSLX - Arrow shapes imported with incorrect rotation and dimension
Status: RESOLVED DUPLICATE of bug 83593
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.2.3.3 release
Hardware: All All
: medium normal
Assignee: Szabolcs Toth
URL:
Whiteboard:
Keywords: filter:xlsx
Depends on:
Blocks: OOXML-Shapes XLSX
  Show dependency treegraph
 
Reported: 2016-11-30 19:31 UTC by Roeland
Modified: 2020-05-29 15:17 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
the original document (45.45 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2016-11-30 19:31 UTC, Roeland
Details
comparison file (20.86 KB, image/png)
2016-11-30 19:32 UTC, Roeland
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roeland 2016-11-30 19:31:24 UTC
Created attachment 129156 [details]
the original document

In the attached document there are some arrows pointing at a certain area. While the look of the arrows is ok in Calc, some of them became shorter and are turned incorrectly.


I added the original Xlsx file, and a png image to compare the outcomes/
.
Comment 1 Roeland 2016-11-30 19:32:10 UTC
Created attachment 129157 [details]
comparison file
Comment 2 Telesto 2016-12-01 14:05:44 UTC
Confirming with:
Version: 5.4.0.0.alpha0+
Build ID: 4130c8def811d1dcc87eacaa8ae48ba02738a790
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-11-29_01:03:18
Locale: nl-NL (nl_NL); Calc: CL
Comment 3 QA Administrators 2018-07-04 02:49:34 UTC Comment hidden (obsolete)
Comment 4 Roeland 2018-11-21 19:44:20 UTC
I just retested with Version: 6.1.3.2 (x64). The situation is still the same.
Comment 5 Regina Henschel 2019-09-15 21:17:44 UTC
Still wrong in Version: 6.4.0.0.alpha0+ (x64)
Build ID: b5f4041ef04f6645cbd91d35f6231573e3042636
CPU threads: 8; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: de-DE (en_US); UI-Language: en-US
Calc: CL
Comment 6 Szabolcs Toth 2020-05-29 15:17:53 UTC

*** This bug has been marked as a duplicate of bug 83593 ***