Bug Hunting Session
Bug 104320 - UX: Inserted images getting centered upon resize with all other anchoring modes except As Character
Summary: UX: Inserted images getting centered upon resize with all other anchoring mod...
Status: RESOLVED DUPLICATE of bug 87720
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Anchor-and-Text-Wrap
  Show dependency treegraph
 
Reported: 2016-12-01 11:14 UTC by Telesto
Modified: 2017-04-21 21:38 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file (13.12 KB, application/vnd.oasis.opendocument.text)
2016-12-01 11:25 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2016-12-01 11:14:53 UTC
Description:
Maybe this isn't a bug, but a feature, but I got confused. When resizing an image from the right to the left, I thought both sides where shrinking.
Jacques Guilleron enlightened me the image was set to be horizontally centered, so the repositioning was normal. But I didn't set the alignment to be centered horizontally, it was LO default.

The 'golden standard', MS Word always aligns images to the left by default. Maybe it should be left in LO too. Just for the sake of migrating purposes from Word to LO.

Steps to Reproduce:
1.Open Writer
2.Insert the attached image
3.2.Resize the image, clicking on the right side of the image, and drag it to the left

Actual Results:  
Inserted images are centered by default

Expected Results:
Inserted image should be alignment to the left side


Reproducible: Always

User Profile Reset: YES

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Comment 1 Telesto 2016-12-01 11:25:59 UTC
Created attachment 129182 [details]
Example file
Comment 2 Buovjaga 2016-12-07 17:29:47 UTC
It's true in all cases except when anchored As Character. I don't see, why this should happen, so accepting as NEW.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.4.0.0.alpha0+
Build ID: 252008d49203344ebe69e727a260a48bc76d7a82
CPU Threads: 8; OS Version: Linux 4.8; UI Render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on December 6th 2016

Arch Linux 64-bit
LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 3 Yousuf Philips (jay) (retired) 2017-04-21 21:38:02 UTC
Inserted images in LibreOffice are center aligned and anchored To Paragraph, which allows them to dragged anywhere around the page. While in MS Word, they are anchored As Character, which limits it to be dragged only where text on the page is, which is why it appears to be left aligned when you drag it.

Closing this as a duplicate of bug 87720, which is to decide what the default formatting of inserted images should be.

*** This bug has been marked as a duplicate of bug 87720 ***