Bug 104339 - SVG file is inserted empty
Summary: SVG file is inserted empty
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
5.2.3.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.4.0 target:5.3.0.2 target:6.4.0
Keywords: bibisected, bisected, filter:svg, regression
: 104593 104958 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-12-02 08:35 UTC by David Tardon
Modified: 2019-09-20 15:34 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
sample SVG (2.34 KB, image/svg+xml)
2016-12-02 08:36 UTC, David Tardon
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Tardon 2016-12-02 08:35:41 UTC
Description:
The attached SVG is inserted as an empty rectangle.

Steps to Reproduce:
1. Use Insert->Image to insert the attached SVG.

Actual Results:  
An empty image.

Expected Results:
A non-empty image.


Reproducible: Always

User Profile Reset: No

Additional Info:
Opening via File->Open works.


User-Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:47.0) Gecko/20100101 Firefox/47.0
Comment 1 David Tardon 2016-12-02 08:36:12 UTC
Created attachment 129224 [details]
sample SVG
Comment 2 MM 2016-12-02 12:20:16 UTC
Unconfirmed with v5.1.6.2 under ubuntu 16.04 x64.
Confirmed with v5.2.3.3 under ubuntu 16.04 x64.
Comment 3 raal 2016-12-05 22:38:32 UTC
This seems to have begun at the below commit.
Adding Cc: to Xisco Fauli; Could you possibly take a look at this one? Thanks

	author	Xisco Fauli <anistenis@gmail.com>	2016-03-06 18:03:27 (GMT)
committer	Xisco Faulí <anistenis@gmail.com>	2016-03-07 08:48:50 (GMT)
commit	d5649ae7b76278cb3155f951d6327157c7c92b65 (patch)
tree	6312127def6dcf68afff21c05d72f88ecac7a2d4
parent	3c465c259c617e30b01c5ea25b5203a605cd4269 (diff)
SVGIO: tdf#97539: clip-path elements might contain...
Comment 4 raal 2016-12-15 16:10:01 UTC
*** Bug 104593 has been marked as a duplicate of this bug. ***
Comment 5 Commit Notification 2016-12-19 00:11:35 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5903235d57acb13d9d5286d23b443a01aeab9a3c

tdf#104339 Partially revert d5649ae7b76278cb3155f951d6327157c7c92b65

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Xisco Faulí 2016-12-28 23:17:43 UTC
*** Bug 104958 has been marked as a duplicate of this bug. ***
Comment 7 Commit Notification 2017-01-04 08:42:23 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f7eeb3fc1dc5d072dbfd22b68cc51f3a2c8ef8b0&h=libreoffice-5-3

tdf#104339 Partially revert d5649ae7b76278cb3155f951d6327157c7c92b65

It will be available in 5.3.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2019-09-19 16:09:51 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/428b67cd0d490739f9a7bb5a724020179ba7591d

tdf#104339: SVGIO: Add unittest

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.