Bug 104342 - Rethinking 'Master pages' sidebar dock
Summary: Rethinking 'Master pages' sidebar dock
Status: RESOLVED DUPLICATE of bug 110436
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Sidebar-Master-Pages
  Show dependency treegraph
 
Reported: 2016-12-02 09:29 UTC by Samuel Mehrbrodt (allotropia)
Modified: 2017-09-24 22:48 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Samuel Mehrbrodt (allotropia) 2016-12-02 09:29:40 UTC
In Impress we have a sidebar deck named "Master pages". It has three sections:
* Used in this presentation
* Recently used
* Available for use

I see a huge problem especially with the last section "Available for use". It lists master slides from all registered templates. People tend to use this as a template switcher, but the result is that you mess your presentation up because you import master slides from foreign templates instead of just using that template as base.

It should be more obvious for the user now (since 5.3) how to select a template since we show the template selection dialog on Impress startup.

So I suggest we remove the "Available for use" sidebar panel.

Maybe we can even go further and remove the whole deck. A master page switcher has been integrated in the properties deck recently.
Another option would be to move the "Used in this presentation" panel to the Properties deck, and remove the "Master slide" selector from there.

Thoughts?
Comment 1 Cor Nouws 2016-12-09 16:11:01 UTC
(In reply to Samuel Mehrbrodt (CIB) from comment #0)
> In Impress we have a sidebar deck named "Master pages". It has three
> sections:
> * Used in this presentation
> * Recently used
> * Available for use
> 
> I see a huge problem especially with the last section "Available for use".

What about "Available master pages from other templates" or 
"Available from other templates" 

> It lists master slides from all registered templates. People tend to use
> this as a template switcher, but the result is that you mess your
> presentation up because you import master slides from foreign templates
> instead of just using that template as base.

Might well happen ;)

> It should be more obvious for the user now (since 5.3) how to select a
> template since we show the template selection dialog on Impress startup.

Indeed.

> So I suggest we remove the "Available for use" sidebar panel.

Mwah... not convinced yet.

> Maybe we can even go further and remove the whole deck. A master page
> switcher has been integrated in the properties deck recently.

Ah, that is nice. (Still some glitches there..)

> Another option would be to move the "Used in this presentation" panel to the
> Properties deck, and remove the "Master slide" selector from there.

It's starting to get confusing for me..

> Thoughts?

The ideas all end in removing to choose from "Available master pages from other templates", correct?
Now we do have the dialog via "Slide > Slide master design". That has been subject of discussion before. Not the last because of a nice mixture of related/(meaning) similar terms.
Comment 2 Yousuf Philips (jay) (retired) 2017-09-24 22:48:12 UTC
I've suggested the removal as well in my duplicate bug. :D

*** This bug has been marked as a duplicate of bug 110436 ***