Bug 104359 - UI: Wrong page associated with HELP Button in dialog File Services
Summary: UI: Wrong page associated with HELP Button in dialog File Services
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.4.0 target:5.3.0.2
Keywords:
Depends on:
Blocks: Dialog-UX
  Show dependency treegraph
 
Reported: 2016-12-02 16:32 UTC by Cor Nouws
Modified: 2021-05-06 19:36 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cor Nouws 2016-12-02 16:32:23 UTC
Choose File Open > Servers..
Click a field and then HELP.
Help page opened: "Welcome to the LibreOffice"

Expected: "Opening and saving files on remote servers"

Version: 5.4.0.0.alpha0+
Build ID: 33f5bc54aaa7fe7aa9335726e30f9c349155e04d
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-12-01_23:51:31
Locale: nl-NL (nl_NL.UTF-8); Calc: group
Comment 1 Julien Nabet 2016-12-02 22:05:50 UTC
Gabor: noticing your work on Help part, thought you might be interested in this one.
Comment 2 Gabor Kelemen (allotropia) 2016-12-04 20:34:01 UTC
I see the page if the local help is installed in a local build, but not in the online case. I get an URL like https://help.libreoffice.org/swriter/fps/ui/remotefilesdialog/add_service_btn?Language=en-US&System=UNIX&Version=5.4 - and nothing there.
This has two reasons:
- the page was added recently in August and the wiki was not updated since then: time will solve this :)
- when building the wiki pages locally I get the following exception:

Unknown paragraph role start: ol_item
Exception in thread Thread-2233:
Traceback (most recent call last):
  File "/usr/lib/python2.7/threading.py", line 810, in __bootstrap_inner
    self.run()
  File "/home/gabor/src/core/helpcontent2/to-wiki/wikiconv2.py", line 1385, in run
    file.write(parser.get_all())
  File "/home/gabor/src/core/helpcontent2/to-wiki/wikiconv2.py", line 1299, in get_all
    return self.head_obj.get_all()
  File "/home/gabor/src/core/helpcontent2/to-wiki/wikiconv2.py", line 363, in get_all
    text = text + i.get_all()
  File "/home/gabor/src/core/helpcontent2/to-wiki/wikiconv2.py", line 1178, in get_all
    if replace_paragraph_role['templ'][role]:
KeyError: u'ol_item'

Surprise-surprise, there is a few ol_item used in 
https://cgit.freedesktop.org/libreoffice/help/tree/source/text/shared/guide/cmis-remote-files.xhp#n42
and in a few other new pages: namely 
source/text/simpress/guide/photo_album.xhp and source/text/swriter/01/title_page.xhp
These seem to be artifacts from the help authoring extension and to-wiki/wikiconv2.py needs to be updated.

Cor: are you using a local build or a prepackaged rpm / deb? 
I'm not sure why you get the welcome page, that might be a completely different problem, which I can't reproduce yet.
Comment 3 Commit Notification 2016-12-14 22:29:38 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=cb54cfefe42d115a08e3c368a028b3f0b30485d4

tdf#104359 (partial) Handle ol_item and ul_item
Comment 4 Commit Notification 2016-12-24 23:32:46 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=019d305ec0f0402d71910a3997ddebaf94df8dd2&h=libreoffice-5-3

tdf#104359 (partial) Handle ol_item and ul_item
Comment 5 Gabor Kelemen (allotropia) 2016-12-29 15:54:50 UTC
Now we have https://help.libreoffice.org/Common/Using_Remote_Files and https://help.libreoffice.org/Common/Using_Remote_Files_1 (amazing titles!) up and working but they are not reached from the UI. 
I think a few bookmarks are missing from the source xhp files.
Comment 6 Cor Nouws 2017-01-16 10:09:34 UTC
polite ping: still an issue in Version: 5.4.0.0.alpha0+
Build ID: ec1afa55e8ed79dc290caff74aaca304a77c3b4f
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-01-14_01:33:36
Locale: nl-NL (nl_NL.UTF-8); Calc: group
Comment 7 Xisco Faulí 2017-09-11 08:50:04 UTC
Dear developer,
This bug has been in ASSIGNED status for more than 3 months without any activity. Resetting it to NEW.
Please assigned it back to yourself if you're still working on this.