Bug 104373 - Writer - Ruler/Margin/Indent Unreadable with Plasma/Breeze Dark Theme
Summary: Writer - Ruler/Margin/Indent Unreadable with Plasma/Breeze Dark Theme
Status: RESOLVED DUPLICATE of bug 94632
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.1.6.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-12-03 12:37 UTC by David C. Rankin
Modified: 2016-12-09 15:20 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot showing Ruler/Margin/Hanging Indent unreadable (and icons too) (30.81 KB, image/png)
2016-12-03 12:37 UTC, David C. Rankin
Details
Screenshot (of complete title bar) showing the problem (44.79 KB, image/png)
2016-12-03 12:41 UTC, David C. Rankin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David C. Rankin 2016-12-03 12:37:16 UTC
Created attachment 129274 [details]
Screenshot showing Ruler/Margin/Hanging Indent unreadable (and icons too)

LO Devs,

  The ruler as well as the margin and hanging-indent controls are unreadable with Plasmas/Frameworks and the default Breeze Dark theme. The primary problem is the ruler background defaults to black leaving a black-on-black foreground/background situation (or read darn close to it). The attached screenshot shows the problem.

  The tab selection is also almost impossible to see. This problem also effect the default (Breeze) icon theme in LO. Notice how the 'Print', 'Print Preview', 'Copy' and 'Cut' icons are invisible in the toolbar.

  LO should detect a dark theme and should adjust the controls accordingly (without the use of Preferences > Accessibility > Detect high-contrast theme. The themes are not high contrast, they are just dark which LO seems to have difficulty handling. As both Gnome and KDE default to darker themes, this is becoming a pressing problem.
Comment 1 David C. Rankin 2016-12-03 12:41:29 UTC
Created attachment 129275 [details]
Screenshot (of complete title bar) showing the problem

Here is an additional screenshot that shown the complete document window and full toolbars/ruler. Don't get me wrong, there are no major changes needed, this is a good look for LO, there are just tweaks needed to fix these specific readability issues.
Comment 2 Buovjaga 2016-12-09 15:20:03 UTC

*** This bug has been marked as a duplicate of bug 94632 ***