Bug 104404 - Extension Manager Help button leads to an empty helpwiki page
Summary: Extension Manager Help button leads to an empty helpwiki page
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
5.2.2.2 release
Hardware: All All
: medium normal
Assignee: Gabor Kelemen
QA Contact:
URL:
Whiteboard: target:5.4.0
Keywords:
Depends on:
Blocks: HelpGaps
  Show dependency treegraph
 
Reported: 2016-12-05 06:53 UTC by Howard Johnson
Modified: 2017-05-09 09:15 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Comment 1 Xisco Faulí 2016-12-05 19:42:36 UTC
Confirmed in

Version: 5.4.0.0.alpha0+
Build ID: 18b3138a7ac4da823e41640bed8a4707029b8fb0
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 2 Xisco Faulí 2016-12-05 19:57:08 UTC
it looks the extension dialog was converted by Caolán Mcnamara.

@Caolán, Could you please take a look whenever you have some time?
Comment 3 Gabor Kelemen 2016-12-27 10:53:46 UTC
This happens because in 5.2 the default selected UI item is the "Bundled with LibreOffice" checkbox. We don't have help content for that and the wiki gives back an empty page.

In 5.3 the default item is the "Check for Updates" button and for that we have help content, although its linking with the UI is a bit messed up.
Comment 4 Commit Notification 2016-12-27 10:58:58 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=1125573f063f864fb7439a82fc71288dcc6d8466

tdf#104404 Fix bookmarks and ahelps on the Extension Manager page
Comment 5 Xisco Faulí 2017-03-01 11:07:33 UTC
Hello Gabor,
Is this bug fixed?
If so, could you please close it as RESOLVED FIXED?
Comment 6 Commit Notification 2017-05-09 08:30:23 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=702ade901c65e4960296a371bd01317e02b581ab

tdf#104404 (related) Document Extension list filtering options