Bug 104502 - FILEOPEN XLS Calc wants to print extra empty pages
Summary: FILEOPEN XLS Calc wants to print extra empty pages
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
5.1.4.2 release
Hardware: All All
: medium normal
Assignee: Attila Szűcs
URL:
Whiteboard: target:7.2.0
Keywords:
Depends on:
Blocks: Print-Range
  Show dependency treegraph
 
Reported: 2016-12-08 15:32 UTC by Gabor Kelemen (allotropia)
Modified: 2021-08-16 09:10 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
The problematic document (82.00 KB, application/vnd.ms-excel)
2016-12-08 15:32 UTC, Gabor Kelemen (allotropia)
Details
Screenshot of the document in LO 5.1.4 and Excel 2013 side by side (181.75 KB, image/png)
2016-12-08 15:37 UTC, Gabor Kelemen (allotropia)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gabor Kelemen (allotropia) 2016-12-08 15:32:22 UTC
Created attachment 129403 [details]
The problematic document

Attached XLS file in Excel spreads to 10 pages.

When opened in Calc it still takes 10 pages (with content slipping 5 lines down), but in Page Break view it indicates there are 18 pages to print. 
Even in print preview with "Suppress output of empty pages" on (default) Calc wants to print 14 pages with the last four being (at least visually) empty.

I have no idea what settings wrong import may cause this.
Comment 1 Gabor Kelemen (allotropia) 2016-12-08 15:37:13 UTC
Created attachment 129404 [details]
Screenshot of the document in LO 5.1.4 and Excel 2013 side by side
Comment 2 Adrian 2016-12-09 10:02:36 UTC
Thank you for reporting the bug. I can confirm that the bug is present in 
LibreOffice Version: 5.1.4.2 Build ID: 1:5.1.4-0ubuntu1
Comment 3 Adrian 2016-12-09 10:18:18 UTC
In Page Break view when I selected all empty rows from the last one, to the one after last line of your text and clicked delete, then it looks like problem solved (screenshots in link: http://imgur.com/a/jmWZW ).
Comment 4 QA Administrators 2018-07-31 02:34:30 UTC Comment hidden (obsolete)
Comment 5 Timur 2018-07-31 13:23:39 UTC
Columns I-L are hidden. Column L has text up to L454. So it makes sense that LO initially sets print area up to row 454.
Dupe of 35591.

*** This bug has been marked as a duplicate of bug 35591 ***
Comment 6 Attila Szűcs 2021-01-25 14:25:47 UTC
it seems this bug is a different bug from 35591,
as this bug is about hidden columns,
while the bug 35591 is about hidden cells.. that is not supported by MS excel. (Format Cells -> Cell Protection -> Hide when printing)
they are stored, and calculated differently.
Comment 7 Commit Notification 2021-02-09 15:38:18 UTC
Attila Szűcs committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/2bf3e0d00e3bccb5b250642ee0d3fdbe6cae8ecc

tdf#104502 sc: skip hidden columns at printing pages

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 NISZ LibreOffice Team 2021-03-09 12:52:12 UTC
Verified in:


Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 72841008bf422dfd8553240b3a78f0474d03523c
CPU threads: 4; OS: Windows 10.0 Build 17134; UI render: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: hu-HU
Calc: threaded Jumbo