Bug 104556 - FILEOPEN DOCX: Misplaced vertical red line (drawing object)
Summary: FILEOPEN DOCX: Misplaced vertical red line (drawing object)
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:docx, regression
: 104555 (view as bug list)
Depends on:
Blocks: OOXML-Shapes WPS-Support
  Show dependency treegraph
 
Reported: 2016-12-10 13:35 UTC by Telesto
Modified: 2018-10-22 21:55 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Native Word 2013, stripped down (39.52 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2017-12-05 22:25 UTC, Luke
Details
LibreOffice 6.1 (108.59 KB, image/png)
2018-03-07 11:57 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2016-12-10 13:35:35 UTC
Description:
Red line is misplaced. For the yellow lines on page 3 I created a separate report. The yellow lines seem to be OK with LibO 4.0.0.3, but the red line is not.

Steps to Reproduce:
1. Open attachment 121978 [details] (bug 97168)
2. Scroll to page 2
2. Compare position of the red line with Word (attachment 121979 [details])


Actual Results:  
Misplaced vertical red line

Expected Results:
Lines should be at the right position 


Reproducible: Always

User Profile Reset: No

Additional Info:
Found in:
Version: 5.4.0.0.alpha0+
Build ID: b894104a0b02a9b074c76feb925389d7bee6a493
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-12-10_01:00:52
Locale: nl-NL (nl_NL); Calc: CL

and in:
Versie: 4.4.6.3 
Build ID: e8938fd3328e95dcf59dd64e7facd2c7d67c704d

and in
Version: 4.3.0.4
Build ID: 62ad5818884a2fc2e5780dd45466868d41009ec0

also, but less prominent, in:
Versie 4.0.0.3 (Bouw-id: 7545bee9c2a0782548772a21bc84a9dcc583b89)
Locale: nl_NL



User-Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Comment 1 Xisco Faulí 2016-12-11 01:43:09 UTC
Confirmed in

Version: 5.4.0.0.alpha0+
Build ID: 7fc84a8e6678e3d0399983f5a078c9b2beb6ee4b
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

Yellow lines in page 3 are also incorrect.

Regression introduced by

author	Miklos Vajna <vmiklos@collabora.co.uk>	2013-12-03 10:59:42 (GMT)
committer	Miklos Vajna <vmiklos@collabora.co.uk>	2013-12-03 14:39:04 (GMT)
commit	57450afb768c085df0ba2344aa94b5f843060178 (patch)
tree	19a4c28083ee2414102d70db2fcf6bd8ec410799
parent	ddbeaada1c7abb0fee88e709f3d6d824f06b39e0 (diff)

DOCX import: declare wps as a supported feature
This means in case we hit an mc:AlternateContent element, we will read
the mc:Choice branch of it, in case wps is the required feature, not the
mc:Fallback one, which contains the information in VML format (after a
lossy conversion).

Adding Cc: to Miklos Vajna
Comment 2 Xisco Faulí 2016-12-11 12:52:32 UTC
*** Bug 104555 has been marked as a duplicate of this bug. ***
Comment 3 Buovjaga 2017-04-25 14:36:22 UTC
After the fix to bug 107104, this is somehow better, but not perfect. The red line is now a bit too low, going outside the gradient rectangle.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.4.0.0.alpha0+
Build ID: f69424ff90f83136027df3063d4c8ddafdf79faa
CPU threads: 8; OS: Linux 4.10; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on April 25th 2016
Comment 4 Luke 2017-12-05 22:25:15 UTC
Created attachment 138230 [details]
Native Word 2013, stripped down

Still reproducible with Version: 6.1.0.0.alpha0+ (x64)
Build ID: eff70347190a6642fd62a9e0b20e4366c39fbc7a

with a native Word 2013 version
Comment 5 Xisco Faulí 2018-03-07 11:57:59 UTC
Created attachment 140427 [details]
LibreOffice 6.1

The document looks almost similar to MSO 2010 in

Version: 6.1.0.0.alpha0+
Build ID: 2affed9bfd72628549df3049ed9f6e6a30fdb5b8
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

I guess we can close this as RESOLVED WORKSFORME

@Telesto, is the report about the yellow lines still open? If so, it should be closed as well
Comment 6 Xisco Faulí 2018-03-07 11:58:56 UTC
Ok, forget it. it's bug 104555 and it's a dupe of this one...