Download it now!
Bug 104560 - FILESAVE Some charts and images lost when saving ODT to DOCX
Summary: FILESAVE Some charts and images lost when saving ODT to DOCX
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.6.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: DOCX
  Show dependency treegraph
 
Reported: 2016-12-10 15:23 UTC by Telesto
Modified: 2017-05-04 16:32 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2016-12-10 15:23:06 UTC
Description:
File is corrupted

Steps to Reproduce:
1. Open attachment 79203 [details] (bug 64500)
2. Save as a new .DOCX file
3. Open then new file in MSOffice

Actual Results:  
Observed behaviour: file is corrupted

Expected Results:
File should be opening


Reproducible: Always

User Profile Reset: No

Additional Info:
Found in:
Version: 5.4.0.0.alpha0+
Build ID: b894104a0b02a9b074c76feb925389d7bee6a493
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-12-10_01:00:52
Locale: nl-NL (nl_NL); Calc: CL

and in
Versie: 4.4.6.3 
Build ID: e8938fd3328e95dcf59dd64e7facd2c7d67c704d
Locale: nl_NL


User-Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Comment 1 Xisco Faulí 2016-12-11 01:27:26 UTC
I can't reproduce it in

Version: 5.4.0.0.alpha0+
Build ID: 7fc84a8e6678e3d0399983f5a078c9b2beb6ee4b
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

and MSOffice 2010
Comment 2 Telesto 2016-12-11 11:14:24 UTC
Hmm, maybe I was a bit too general with MSoffice. The issue exists with Word Viewer in combination with Microsoft Open XML Converter.
Comment 3 Buovjaga 2016-12-14 18:35:20 UTC
It opens fine in MSO2013 - yet, some of the charts and images are missing. You don't need MSO to note this, though: LibO displays the DOCX with the missing objects as well.

I wouldn't trust Word Viewer to deal with DOCXes correctly. I've noticed weirdness with it myself.

Changing summary.

Version: 5.4.0.0.alpha0+
Build ID: 055fd58711d57af4d96214aebd71b713303d5527
CPU Threads: 4; OS Version: Windows 6.29; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-12-01_09:53:48
Locale: fi-FI (fi_FI); Calc: group
Comment 4 Timur 2017-05-04 16:32:47 UTC
(In reply to Buovjaga from comment #3)
> It opens fine in MSO2013
so Invalid, because this is MSO and RT is bug 64500.