Download it now!
Bug 104565 - FILEOPEN DOCX: Positioning of arrows is off in LO (after round trip)
Summary: FILEOPEN DOCX: Positioning of arrows is off in LO (after round trip)
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3 all versions
Hardware: All All
: medium normal
Assignee: Szabolcs Toth
URL:
Whiteboard: target:7.0.0 target:6.4.4
Keywords: bibisected, bisected, filter:docx, regression
: 114949 123617 (view as bug list)
Depends on:
Blocks: OOXML-Shapes
  Show dependency treegraph
 
Reported: 2016-12-10 19:08 UTC by Telesto
Modified: 2020-04-21 14:42 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file (9.40 KB, application/vnd.oasis.opendocument.text)
2016-12-10 19:08 UTC, Telesto
Details
Same result in MSO 2010 and LibreOffice 5.4 (58.57 KB, image/png)
2016-12-11 12:50 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2016-12-10 19:08:11 UTC
Description:
Positioning of arrows is off in LO but not in Word

Steps to Reproduce:
1.Open the file in LibreOffice
2.Click File -> Save As (Microsoft Word 2007/2010 (.docx))
3.Close file
4.Re-open saved file in LibO (and in Word)

Actual Results:  
Exported file is fine in Word, but not in LibO

Expected Results:
File saved by LibO should be opened correctly


Reproducible: Always

User Profile Reset: No

Additional Info:
Found in:
Version: 5.4.0.0.alpha0+
Build ID: b894104a0b02a9b074c76feb925389d7bee6a493
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-12-10_01:00:52
Locale: nl-NL (nl_NL); Calc: CL

and in
Versie: 4.4.6.3 
Build ID: e8938fd3328e95dcf59dd64e7facd2c7d67c704d
Locale: nl_NL


User-Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Comment 1 Telesto 2016-12-10 19:08:53 UTC
Created attachment 129462 [details]
Example file
Comment 2 Xisco Faulí 2016-12-11 12:50:48 UTC
Created attachment 129494 [details]
Same result in MSO 2010 and LibreOffice 5.4
Comment 3 Xisco Faulí 2016-12-11 12:51:33 UTC
Confirmed in

Version: 5.4.0.0.alpha0+
Build ID: 7fc84a8e6678e3d0399983f5a078c9b2beb6ee4b
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

but not in

Version: 4.3.0.0.alpha0+
Build ID: 52cc0c8f05d40db6d076c13f8b8d6d9453ec8930
Comment 5 QA Administrators 2018-09-14 02:47:12 UTC Comment hidden (obsolete)
Comment 6 Roman Kuznetsov 2018-09-14 09:58:36 UTC
still repro in LO 6.1.1.1

MS Word and Writer open result DOCX same wrong
Comment 7 Buovjaga 2019-04-14 12:15:41 UTC
Bibisected with win32-4.3 to https://gerrit.libreoffice.org/plugins/gitiles/core/+/c6ff03f37a6898f50a5ca07152168fb4fe911e05%5E!/
fdo#70838: apply rotation transformations to DML anchor position

Adding Cc: to Jacobo Aragunde Pérez
Comment 8 Commit Notification 2020-04-08 10:55:37 UTC
Szabolcs committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/08a11f8fe19560b000c62da00d7425b4f500d605

tdf#104565 DOCX drawing object export: fix arrow positions

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Xisco Faulí 2020-04-14 10:45:49 UTC
Verified in

Version: 7.0.0.0.alpha0+
Build ID: 35fc5ef0a759884b24ed8b83cd05702a0fab64cc
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

@Szabolcs Toth, thanks for fixing this issue!!
Comment 10 Commit Notification 2020-04-14 10:58:06 UTC
Szabolcs committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/b81e6e18353b68fe41e805e9f047e787963a53f2

tdf#104565 DOCX drawing object export: fix arrow positions

It will be available in 6.4.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Gabor Kelemen 2020-04-14 20:49:15 UTC
*** Bug 114949 has been marked as a duplicate of this bug. ***
Comment 12 NISZ LibreOffice Team 2020-04-21 14:42:57 UTC
*** Bug 123617 has been marked as a duplicate of this bug. ***