Bug 104572 - Crash when selecting paste special > more options (GTK+)
Summary: Crash when selecting paste special > more options (GTK+)
Status: RESOLVED DUPLICATE of bug 104687
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
5.4.0.0.alpha0+
Hardware: x86-64 (AMD64) Linux (All)
: highest critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, haveBacktrace, regression
Depends on:
Blocks:
 
Reported: 2016-12-10 22:55 UTC by MM
Modified: 2016-12-20 00:54 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
backtrace (118.01 KB, text/x-log)
2016-12-13 22:37 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description MM 2016-12-10 22:55:00 UTC
Steps to reproduce:

- In draw / impress make (for example) a rectangle.
- Open writer
- Copy the rectangle from draw/impress
- in writer select RMB > paste special > more options
- now a box appears with an exclamation mark and LO crashes.

If you select paste special from the menu, then it works, no crash.

Tested with ubuntu 16.04 x64.

Confirmed with Version: 5.4.0.0.alpha0+
Build ID: b52167df08511239c3d08904a3d12a3c92141f38
CPU Threads: 2; OS Version: Linux 4.4; UI Render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-12-10_00:00:32
Locale: en-US (en_US.UTF-8); Calc: single

but

Unconfirmed with Version: 5.3.0.0.alpha1+
Build ID: 883024d657fb45c7da459017d2f936aac5644bfb
CPU Threads: 2; OS Version: Linux 4.4; UI Render: default; VCL: gtk2; Layout Engine: new; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-11-21_22:42:51
Locale: en-US (en_US.UTF-8); Calc: single
Comment 1 Xisco Faulí 2016-12-10 23:42:36 UTC
Confirmed in

Version: 5.4.0.0.alpha0+
Build ID: 7fc84a8e6678e3d0399983f5a078c9b2beb6ee4b
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk2; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

but not in

Version: 5.4.0.0.alpha0+
Build ID: 7fc84a8e6678e3d0399983f5a078c9b2beb6ee4b
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 2 Xisco Faulí 2016-12-13 22:37:52 UTC
Created attachment 129610 [details]
backtrace
Comment 3 Xisco Faulí 2016-12-20 00:25:05 UTC
Regression introduced by:

author  Kohei Yoshida <kohei.yoshida@collabora.com>     2016-11-22 03:56:46
(GMT)
committer       Kohei Yoshida <libreoffice@kohei.us>    2016-11-22 13:18:00
(GMT)
commit  87e040fd0f04307534920d0765af6d5878794a98 (patch)
tree    8faa3f12d311d9c1fc205d9c333e2b15da934894
parent  a0ef7474521413c8967559a635e6fdc0d88f1df6 (diff)
tdf#71409: Stop listening to objects going out-of-focus.
This helps eliminate the number of AtkListener objects growing
over time.

Closing this as duplicate of bug 104687

*** This bug has been marked as a duplicate of bug 104687 ***
Comment 4 MM 2016-12-20 00:54:03 UTC
Weird that you closed this one, as the other one is newer...