Bug 104575 - LO53b2 OSX: UI text now less readable/cleanly rendered
Summary: LO53b2 OSX: UI text now less readable/cleanly rendered
Status: RESOLVED DUPLICATE of bug 103765
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.3.0.0.beta2
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-12-11 10:15 UTC by Martin Srebotnjak
Modified: 2016-12-11 10:46 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Paragraph Dialog in 5.2.4.1 on OSX (132.01 KB, image/png)
2016-12-11 10:16 UTC, Martin Srebotnjak
Details
Paragraph Dialog in 5.3b2 on OSX (129.91 KB, image/png)
2016-12-11 10:17 UTC, Martin Srebotnjak
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Srebotnjak 2016-12-11 10:15:58 UTC
Description:
Since 5.3b1 on OSX the UI text (in dialogs, toolbars, status bar etc.) is rendered differently, also with another narrower font (AFAICS).
I am not sure if that is a direct consequence of using HarfBuzz or of some other change.
But the UI is much less readable; it seems that with 5.2.x it was rendered in system font and had also much less smear in rendering the UI text.
I am attaching the screenshot of the same dialog (in 5.3b2 the same dialog is also rendered much bigger, but that might be another issue).

Steps to Reproduce:
1. Open LibreOffice
2. Open any dialog etc.
3.

Actual Results:  
Rendered text in 5.3.x UI is very narrow, smudged, less readable on OSX.

Expected Results:
UI as readable or better readable than in 5.2.x on OSX.


Reproducible: Always

User Profile Reset: No

Additional Info:
I am using experimental features and Slovenian (sl) language pack on OSX 10.12.1.


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:50.0) Gecko/20100101 Firefox/50.0
Comment 1 Martin Srebotnjak 2016-12-11 10:16:54 UTC
Created attachment 129484 [details]
Paragraph Dialog in 5.2.4.1 on OSX
Comment 2 Martin Srebotnjak 2016-12-11 10:17:46 UTC
Created attachment 129485 [details]
Paragraph Dialog in 5.3b2 on OSX
Comment 3 Mike Kaganski 2016-12-11 10:46:49 UTC

*** This bug has been marked as a duplicate of bug 103765 ***