Bug 104602 - FILEOPEN DOCX: File appears to be empty
Summary: FILEOPEN DOCX: File appears to be empty
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4 all versions
Hardware: All All
: medium normal
Assignee: Justin L
URL:
Whiteboard: target:6.0.0 target:5.4.2 target:5.3.8
Keywords: bibisected, bisected, filter:docx, regression
: 111895 111899 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-12-12 11:44 UTC by Telesto
Modified: 2017-11-08 08:34 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file (17.53 KB, application/vnd.openxmlformats)
2016-12-12 11:45 UTC, Telesto
Details
File in MS Word Viewer (18.23 KB, application/pdf)
2016-12-12 14:43 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2016-12-12 11:44:15 UTC
Description:
File appears to be empty

Steps to Reproduce:
1. Open attached file in LiBO and Word

Actual Results:  
File is empty in LibO

Expected Results:
File should show a needle


Reproducible: Always

User Profile Reset: No

Additional Info:
Found in
Version: 5.4.0.0.alpha0+
Build ID: 84f2ff67a7e404febf710b1dc7f66d06745c503f
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-12-09_23:20:01
Locale: nl-NL (nl_NL); Calc: CL

and in
Versie: 4.4.6.3 
Build ID: e8938fd3328e95dcf59dd64e7facd2c7d67c704d
Locale: nl_NL


User-Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Comment 1 Telesto 2016-12-12 11:45:02 UTC
Created attachment 129522 [details]
Example file
Comment 2 Telesto 2016-12-12 12:06:46 UTC
Could be a dupe of bug 104419
Comment 3 Telesto 2016-12-12 14:43:51 UTC
Created attachment 129529 [details]
File in MS Word Viewer
Comment 4 Xisco Faulí 2016-12-12 15:31:59 UTC
Regression introduced by:

author	Armin Le Grand <alg@apache.org>	2014-06-02 15:00:50 (GMT)
committer	Miklos Vajna <vmiklos@collabora.co.uk>	2014-07-01 11:30:09 (GMT)
commit	7d9bb549d498d6beed2c4050c402d09643febdfa (patch)
tree	2caf67e36c9ccd058268b003cf2bc39b9b102b53
parent	a5e137eb1d37361c60175e8fba780fc46b377a23 (diff)
Related: #i124638# Second step of DrawingLayer FillAttributes...
for Writer objects, now added support for Paragraph and PageStyle (including
Header and Footer) for direct attributes and style attributes

Adding Cc: to Armin Le Grand
Comment 5 Justin L 2017-08-30 22:33:25 UTC
*** Bug 111895 has been marked as a duplicate of this bug. ***
Comment 6 Justin L 2017-08-30 22:52:23 UTC
proposed fix at https://gerrit.libreoffice.org/41744

Ultimately, this bug comes from the DOCX compatibility setting that re-writes backgrounds. When Armin's 4.4 patch came in, the PaintBackground code now was able to re-apply that background as well.

author	Miklos Vajna 2012-09-12 07:59:27 (GMT)
commit	18b3feb8bef06bf7b126fd0bc743e19479cb8026
      n#778133 sw: add BackgroundParaOverDrawings compat flag
Comment 7 Justin L 2017-08-30 22:53:28 UTC
*** Bug 111899 has been marked as a duplicate of this bug. ***
Comment 8 Commit Notification 2017-09-04 09:05:59 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=de0993097cad2fd5819f8bea5ff53cddce7cde41

tdf#104602: don't re-draw page background when bOnlyTextBackground

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Justin L 2017-09-04 18:45:36 UTC
requested backport to 5.4
Comment 10 Commit Notification 2017-09-08 10:18:18 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7117e92448ea328bd4798e873a2faecda748a369&h=libreoffice-5-4

tdf#104602: don't re-draw page background when bOnlyTextBackground

It will be available in 5.4.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2017-11-08 08:15:33 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0dda116236e1532f2006f488b974bb9c7067ac5f&h=libreoffice-5-3

tdf#104602: don't re-draw page background when bOnlyTextBackground

It will be available in 5.3.8.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.