Bug Hunting Session
Bug 104642 - Kerning on macOS broken using Helvetica Neue
Summary: Kerning on macOS broken using Helvetica Neue
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.0.0.alpha0+
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Font-Rendering
  Show dependency treegraph
 
Reported: 2016-12-13 14:14 UTC by steve -_-
Modified: 2018-04-07 17:26 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
kerning broken helvetia neue 12pt 65% zoom screenshot (148.51 KB, image/png)
2016-12-13 14:15 UTC, steve -_-
Details
test file that shows broken on macOS 10.12.1 (11.79 KB, application/vnd.oasis.opendocument.text)
2016-12-13 14:16 UTC, steve -_-
Details
Screenshot at 162% (106.70 KB, image/png)
2016-12-13 16:16 UTC, Telesto
Details
Screenshot at 50% (95.43 KB, image/png)
2016-12-13 16:30 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description steve -_- 2016-12-13 14:14:28 UTC
Description:
Kerning issues have been happening for a while. I am not sure if this is new or regression, I rather think it has been going on for quite some time, but can't pinpoint the exact version this started (and don't have time at this moment).

Interestingly this seems to be only with this old odt file. When creating a new file with identical font usage the kerning issue is not happening.

File is an older file. This is on macOS 10.12.1 + LO master from 2016-12-09.

Steps to Reproduce:
1. Open attached testfile
2. look at font kerning
and compare with attached screenshot indicating the problem

Actual Results:  
kerning is broken

Expected Results:
kerning should be fine


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:50.0) Gecko/20100101 Firefox/50.0
Comment 1 steve -_- 2016-12-13 14:15:42 UTC
Created attachment 129583 [details]
kerning broken helvetia neue 12pt 65% zoom screenshot
Comment 2 steve -_- 2016-12-13 14:16:17 UTC
Created attachment 129584 [details]
test file that shows broken on macOS 10.12.1
Comment 3 Alex Thurgood 2016-12-13 15:02:21 UTC
Confirming with test file and 

Version: 5.4.0.0.alpha0+
Build ID: 9b7ae664e5cf91515435b4b630ffddda57b8d668
CPU Threads: 2; OS Version: Mac OS X 10.12.1; UI Render: default; 
Locale: fr-FR (fr_FR.UTF-8); Calc: group


at page magnification > 180% : kerning good

at page magnification : 100% < x < 180% : kerning bad

at page magnification 100% : kerning good 

at page magnification : 75% < x < 100% : kerning bad

at page magnification : 75% : kerning good

at page magnification < 75% : kerning bad
Comment 4 Alex Thurgood 2016-12-13 15:02:56 UTC
Seems to be some kind of rounding issue with the hinting ?
Comment 5 Alex Thurgood 2016-12-13 15:03:18 UTC
@Khaled : any ideas ?
Comment 6 Alex Thurgood 2016-12-13 15:08:02 UTC
As to whether this is completely new, some fonts definitely already had kerning issues on MacOS previous to the switch over to the new font display implementation, whether Helvetica Neue was one of them is a question to which I don't have the answer, as I use Arial most of the time.
Comment 7 Telesto 2016-12-13 16:16:54 UTC
Created attachment 129595 [details]
Screenshot at 162%

I'm not seeing anything out of the ordinary.. 

Version: 5.4.0.0.alpha0+
Build ID: b52167df08511239c3d08904a3d12a3c92141f38
CPU Threads: 4; OS Version: Mac OS X 10.12.1; UI Render: default; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2016-12-09_23:41:33
Locale: nl-NL (nl_NL.UTF-8); Calc: group
Comment 8 Telesto 2016-12-13 16:30:27 UTC
Created attachment 129596 [details]
Screenshot at 50%
Comment 9 steve -_- 2016-12-16 16:10:18 UTC
Kerning is limited to webview, looks good in normal view.
Comment 10 Telesto 2016-12-18 14:22:10 UTC
In can't reproduce it. With or without GL. Web View or normal view; at any page magnification.. I don't see font kerning.
Version: 5.4.0.0.alpha0+
Build ID: 8ad521d9147df325b7aee27d8e5c670a02e6afcf
CPU Threads: 4; OS Version: Mac OS X 10.12.1; UI Render: GL; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2016-12-15_12:09:40
Locale: nl-NL (nl_NL.UTF-8); Calc: group

Macbook Air 2014. 11,6 Inch
Comment 11 Johnny_M 2017-05-13 18:46:04 UTC
This could be another manifestation of the bug 103322, which is more visible the smaller the screen resolution is.

@steve -_-: What's your screen resolution?
Comment 12 steve -_- 2017-05-21 07:55:39 UTC
15,4-Zoll (1680 x 1050)
Comment 13 steve -_- 2018-04-07 17:26:01 UTC
Version: 6.0.3.2
Build ID: 8f48d515416608e3a835360314dac7e47fd0b821
CPU threads: 8; OS: Mac OS X 10.13.4; UI render: default; 
Locale: de-DE (de_DE.UTF-8); Calc: group

Can no longer reproduce. setting to worksforme.