Bug 104670 - FILEOPEN 2007 DOCX: Text in shape rendered upside down (OK if resaved in MSO)
Summary: FILEOPEN 2007 DOCX: Text in shape rendered upside down (OK if resaved in MSO)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.3.0
Keywords: filter:docx
Depends on:
Blocks: OOXML-Shapes
  Show dependency treegraph
 
Reported: 2016-12-14 10:15 UTC by Telesto
Modified: 2019-07-22 01:26 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file (16.36 KB, application/vnd.openxmlformats-officedocument.wordprocessingml)
2016-12-14 10:15 UTC, Telesto
Details
Example file resaved in MSO 2016 (23.95 KB, application/vnd.ms-word.document)
2018-12-17 13:51 UTC, Timur
Details
Screenshot of the original document side by side in Writer 6.2 and 6.3 (124.19 KB, image/png)
2019-07-15 15:14 UTC, Gabor Kelemen (allotropia)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2016-12-14 10:15:06 UTC
Description:
The text 'Delusion A' is rendered upside down.

Steps to Reproduce:
1.Open attached file

Actual Results:  
Text is upside down

Expected Results:
Text shouldn't be upside down


Reproducible: Always

User Profile Reset: No

Additional Info:
Found in
Version: 5.4.0.0.alpha0+
Build ID: ba6b35fc68a01aff72b39eb7809bacb326068668
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-12-13_06:07:39
Locale: nl-NL (nl_NL); Calc: CL

and in
Versie: 4.4.6.3 
Build ID: e8938fd3328e95dcf59dd64e7facd2c7d67c704d
Locale: nl_NL

and in
Version: 4.4.0.3
Build ID: de093506bcdc5fafd9023ee680b8c60e3e0645d7
Locale: nl_NL

and in
Version: 4.3.0.4
Build ID: 62ad5818884a2fc2e5780dd45466868d41009ec0

but not in
Versie: 4.1.0.4 
Build ID: 89ea49ddacd9aa532507cbf852f2bb22b1ace28


User-Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Comment 1 Telesto 2016-12-14 10:15:46 UTC
Created attachment 129621 [details]
Example file
Comment 2 Telesto 2016-12-14 10:51:27 UTC
Also not in:
Versie: 4.2.0.4 
Build ID: 05dceb5d363845f2cf968344d7adab8dcfb2ba71
Comment 3 Xisco Faulí 2016-12-14 11:02:47 UTC
Regression introduced by:

author	Andras Timar <andras.timar@collabora.com>	2014-04-23 11:11:07 (GMT)
committer	Andras Timar <andras.timar@collabora.com>	2014-04-23 11:12:18 (GMT)
commit 1e48bfcd7aa811d31ecdf9df897b30cffebd5669 (patch)
tree 8ba7b5e86ef310e291d40dfc8e5a28aaece70306
parent b5ac3468e8f186ad807bdd737d7a846320dc30c5 (diff)
fdo#76878 Revert "Resolves: #i116244# need to reset rotation..."

Adding CC: to Andras Timar
Comment 4 Aron Budea 2016-12-15 04:53:02 UTC
Xisco, the mentioned commit is reverting another commit that caused a regression itself, bug 76878.

Can you verify by going back to the commit corresponding to source hash 20dee85b6390ef3edc5434889523cd9fd0137bae in the bibisect repo, and comparing results with the preceding commit's? Please remove regression-related keywords if that's the case.
Comment 5 Xisco Faulí 2016-12-15 09:52:15 UTC
Hello Aron,
Yes, you're right, before 20dee85b6390ef3edc5434889523cd9fd0137bae the issue could be already reproduced in LibreOffice, so it was temporary fixed by that commit. Removing keywords bibisected, bisected, and regression and Adding Armin to the loop to see if he can take a look at it at some point...
Comment 6 QA Administrators 2017-12-16 03:30:19 UTC Comment hidden (obsolete)
Comment 7 Regina Henschel 2017-12-16 20:55:25 UTC
The error is still in Version: 6.1.0.0.alpha0+ (x64)
Build ID: 07138b4f5cd5dc2585b9f63f68f3e2badd34d3c7
CPU threads: 8; OS: Windows 10.0; UI render: GL; 
Locale: de-DE (de_DE); Calc: CL

Not only the Text is wrong, but the shape itself is faulty drawn too.
Comment 8 QA Administrators 2018-12-17 03:41:41 UTC Comment hidden (obsolete)
Comment 9 Regina Henschel 2018-12-17 12:40:33 UTC
The error still exists in Version: 6.3.0.0.alpha0+ (x64)
Build ID: beae6c7a7f163daad0d4dea63a3d403af2745fd1
CPU threads: 8; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-12-07_01:25:50
Locale: de-DE (en_US); UI-Language: en-US
Calc: threaded


The object is a special "Text Box", which is shown in "Compatibility" mode of Ms Word 365 (1811). If the file is converted to current version by MS Word, the object is changed to a drawing object and LibreOffice opens it correctly.
Comment 10 Timur 2018-12-17 13:49:25 UTC
Shape seen from LO 4.1 and text was rendered OK. From 4.3 NOK. Could be regression.
Comment 11 Timur 2018-12-17 13:51:38 UTC
Created attachment 147621 [details]
Example file resaved in MSO 2016

If example file resaved in MSO 2016, LO opens shape and text correctly.
Original example file opens text wrong and shape with excessive lines.
Comment 12 Gabor Kelemen (allotropia) 2019-07-15 15:14:24 UTC
Created attachment 152787 [details]
Screenshot of the original document side by side in Writer 6.2 and 6.3

Seems to be working in:
Verzió: 6.3.0.1 (x86)
Build az.: 41ac97386aba908b6db860cfb4cfe2da871886ae
CPU szálak: 4; OS: Windows 6.3; Felületmegjelenítés: GL; VCL: win; 
Területi beállítások: hu-HU (hu_HU); UI-Language: hu-HU
Calc: CL
Comment 13 Aron Budea 2019-07-22 01:26:35 UTC
Reverse-bibisected to the following commit from Noel, thanks for the unexpected fix! Let's close as fixed.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=f8d29fea9915a5fe66e4ba24cbd3b248929b51b7
author		Noel Grandin <noel.grandin@collabora.co.uk>	2019-05-10 15:47:53 +0200
committer	Noel Grandin <noel.grandin@collabora.co.uk>	2019-05-11 09:09:52 +0200

handle empty tools::Rectangle in svx