Bug 104731 - Formulas in many cells are totally corrupted when some other data in the spreadsheet in transposed
Summary: Formulas in many cells are totally corrupted when some other data in the spre...
Status: RESOLVED DUPLICATE of bug 68976
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.2.2.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-12-17 10:28 UTC by Andy
Modified: 2016-12-17 15:08 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Fle to reproduce the bug (13.45 KB, application/vnd.oasis.opendocument.spreadsheet)
2016-12-17 10:30 UTC, Andy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andy 2016-12-17 10:28:18 UTC
Description:
A simple paste special with transpose operation results in the complete corruption of formulas in other range on the sheet, that have no relation whatsoever with the cells where the paste operation is enacted. See below "steps to reproduce" for details.

Steps to Reproduce:
1. Open the attached file. in the range A1:E9 there are some formulas, that have only references within that range (check it out if you want).

2. Now select the data in range A15:G16, cut it, select as active cell A15 and paste special the data there using the "transpose" button. 
3. The direct result is ok, but as a result, most formulas in the rage above A1:E9 get totally corrupted since their references to other cells are changed in an apparently random fashion.
4. This results in a complete mess and loss of the correct formulas in A1:E9
 

Actual Results:  
Formulas get their references messed up completely

Expected Results:
Nothing should change to formulas in A1:E9 range


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0
Comment 1 Andy 2016-12-17 10:30:02 UTC
Created attachment 129716 [details]
Fle to reproduce the bug
Comment 2 m.a.riosv 2016-12-17 15:08:00 UTC

*** This bug has been marked as a duplicate of bug 68976 ***