Bug 104755 - Less error boxes when trying to export a PDF to an existing file in use by a different application
Summary: Less error boxes when trying to export a PDF to an existing file in use by a ...
Status: RESOLVED DUPLICATE of bug 53530
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
4.4.6.3 release
Hardware: All All
: low enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: PDF-Export
  Show dependency treegraph
 
Reported: 2016-12-18 17:02 UTC by Telesto
Modified: 2018-03-30 08:40 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2016-12-18 17:02:13 UTC
Description:
When saving to an existing file which is in use by a different application three(!) non helpful error boxes popup. 



Steps to Reproduce:
1.Create a PDF test.pdf
2.Open the test.pdf with a pdf viewer
3.Open Writer select Export PDF and try to export to "test.pdf" (overwriting the original) 

Actual Results:  
1. Error saving the document mp07_embedded_ppt:
Access to C:\Users\DEMO\Desktop\mp07_embedded_ppt.pdf was denied.
2. Error saving the document mp07_embedded_ppt:
Access to C:\Users\DEMO\Desktop\mp07_embedded_ppt.pdf was denied.
3 Error saving the document mp07_embedded_ppt:
General Error.
General input/output error.

Expected Results:
Something like 'test.pdf' is locked for editing by yourself on a different system since 18.12.2016 17:57
Close document on other system and retry saving or ignore own file locking and save current document.


Reproducible: Always

User Profile Reset: No

Additional Info:
Version: 5.4.0.0.alpha0+
Build ID: 53edf60c4ce6ed32f87471e018878c40b788005a
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-12-18_06:57:59
Locale: nl-NL (nl_NL); Calc: CL


User-Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Comment 1 Buovjaga 2016-12-19 16:13:24 UTC
Yep, a good observation.

Version: 5.4.0.0.alpha0+
Build ID: 53edf60c4ce6ed32f87471e018878c40b788005a
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-12-18_07:01:05
Locale: fi-FI (fi_FI); Calc: group
Comment 2 Timur 2018-03-30 08:40:48 UTC

*** This bug has been marked as a duplicate of bug 53530 ***