Bug 104784 - FILESAVE: PPTX: Corrupted File after RT (The element has incomplete content)
Summary: FILESAVE: PPTX: Corrupted File after RT (The element has incomplete content)
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.4.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:pptx
Depends on:
Blocks: PPTX-Corrupted
  Show dependency treegraph
 
Reported: 2016-12-19 15:25 UTC by Xisco Faulí
Modified: 2017-11-18 02:42 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
sample2 (50.95 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2016-12-19 16:50 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2016-12-19 15:25:48 UTC
Steps:
1. Open attachment 126833 [details] from bug 101527
2. Save it as a new .PPTX
3. Open the new .PPTX file in MSO PowerPoint

Error from Open XML SDK 2.5: ChildTimeNodeList

Reproduced in

Version: 5.4.0.0.alpha0+
Build ID: 53edf60c4ce6ed32f87471e018878c40b788005a
CPU Threads: 1; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-12-18_06:57:59
Locale: es-ES (es_ES); Calc: group
Comment 1 Xisco Faulí 2016-12-19 15:42:16 UTC
Error Node type: ChildTimeNodeList
Error Description: The element has incomplete content
Comment 2 Xisco Faulí 2016-12-19 16:50:04 UTC
Created attachment 129785 [details]
sample2
Comment 3 Xisco Faulí 2016-12-19 18:02:32 UTC
Another file: attachment 60731 [details] from bug 49251
Comment 4 Xisco Faulí 2016-12-20 00:04:58 UTC
*** Bug 95503 has been marked as a duplicate of this bug. ***
Comment 5 Buovjaga 2016-12-20 09:57:15 UTC
Repro.

Win 8.1 32-bit
MSO 2013
LibO Version: 5.4.0.0.alpha0+
Build ID: 52853b53494e1e51d71ccdb54afd7a4f16fba93c
CPU Threads: 4; OS Version: Windows 6.29; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-12-19_23:19:20
Locale: fi-FI (fi_FI); Calc: group
Comment 6 Jan Holesovsky 2017-08-10 13:16:52 UTC
I believe this is the same thing too.

*** This bug has been marked as a duplicate of bug 111518 ***
Comment 7 Xisco Faulí 2017-08-31 22:50:50 UTC
Still reproducible in

Version: 6.0.0.0.alpha0+
Build ID: 04d70c0999c716f5465631eca50945915ec607c4
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 8 Xisco Faulí 2017-08-31 22:59:01 UTC
Validating in Open XML SDK 2.5 I get:

AttributeNameList - The element has incomplete content
VariantValue - The element has incomplete content
Comment 9 Aron Budea 2017-11-18 02:42:59 UTC
PowerPoint opens the roundtripped samples fine when using a recent master build, and they also give no errors with Open XML SDK 2.5 validator.

Version: 6.0.0.0.alpha1+
Build ID: 318f2c9ad00b0cea709d135eff11809fdd27633f
CPU threads: 16; OS: Windows 6.1; UI render: default; 
Locale: hu-HU (hu_HU); Calc: CL