Bug 104786 - FILESAVE: PPTX: Corrupted File after RT (The element has invalid child element)
Summary: FILESAVE: PPTX: Corrupted File after RT (The element has invalid child element)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.4.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Szymon Kłos
URL:
Whiteboard: target:6.1.0 target:6.0.4
Keywords: filter:pptx
: 112868 (view as bug list)
Depends on:
Blocks: PPTX-Corrupted Custom-Animations
  Show dependency treegraph
 
Reported: 2016-12-19 15:58 UTC by Xisco Faulí
Modified: 2018-03-20 09:00 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
sample (34.98 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2016-12-19 15:58 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2016-12-19 15:58:57 UTC
Created attachment 129784 [details]
sample

Steps:
1. Open attached document
2. Save it as a new .PPTX
3. Open the new .PPTX file in MSO PowerPoint

Error Node Type: Animate
Error Description: The element has invalid child element 'http://schemas.openxmlformats.org/presentationml/2006/main:to'
Number of errors: 6

Reproduced in

Version: 5.4.0.0.alpha0+
Build ID: 53edf60c4ce6ed32f87471e018878c40b788005a
CPU Threads: 1; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-12-18_06:57:59
Locale: es-ES (es_ES); Calc: group
Comment 1 Buovjaga 2016-12-20 09:54:03 UTC
Repro.

Win 8.1 32-bit
MSO 2013
LibO Version: 5.4.0.0.alpha0+
Build ID: 52853b53494e1e51d71ccdb54afd7a4f16fba93c
CPU Threads: 4; OS Version: Windows 6.29; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-12-19_23:19:20
Locale: fi-FI (fi_FI); Calc: group
Comment 2 Aron Budea 2017-10-21 21:00:24 UTC
*** Bug 112868 has been marked as a duplicate of this bug. ***
Comment 3 Xisco Faulí 2018-02-15 17:24:09 UTC
Still reproducible in

Version: 6.1.0.0.alpha0+
Build ID: 48d3ff5c498f8f186d4ee72871af379010403442
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 4 Commit Notification 2018-03-16 08:06:04 UTC
Szymon Kłos committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4f90f35c6f95787cef1e8acb66cfc58f884be8dc

tdf#104786 Don't export empty 'to'

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2018-03-20 09:00:12 UTC
Szymon Kłos committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=544cf7f6750715ae25bdb3d0904672f7432f5c2f&h=libreoffice-6-0

tdf#104786 Don't export empty 'to'

It will be available in 6.0.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.