Download it now!
Bug 104794 - CPU usage reaches its max when dragging a complex, animated gif around
Summary: CPU usage reaches its max when dragging a complex, animated gif around
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: perf
Depends on:
Blocks:
 
Reported: 2016-12-19 19:52 UTC by Telesto
Modified: 2017-12-22 11:09 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2016-12-19 19:52:45 UTC
Description:
CPU maxes out when dragging a complex, animated gif

Steps to Reproduce:
1.Download http://forums.x-plane.org/uploads/monthly_2016_07/GPS24golden.gif.5d39c488452fdbfe7ac47db70df3cbc8.gif
2.Open Impress
3.Add gif to Impress sheet 
4.Drag the gif around
2.Take notice of CPU usage

Actual Results:  
Maxing out CPU

Expected Results:
Around 4 or 5% with the same solution as in Writer. Disable animation when dragging.


Reproducible: Always

User Profile Reset: No

Additional Info:
Found in
Version: 5.4.0.0.alpha0+
Build ID: 53edf60c4ce6ed32f87471e018878c40b788005a
CPU Threads: 4; OS Version: Windows 6.19; UI Render: GL; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-12-18_06:57:59
Locale: nl-NL (nl_NL); Calc: CL

and in
Versie: 4.4.6.3 
Build ID: e8938fd3328e95dcf59dd64e7facd2c7d67c704d
Locale: nl_NL


User-Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Comment 1 Buovjaga 2016-12-20 19:50:28 UTC
This seems the same as bug 98500 (the summary says "multiple", but description speaks of slowness even with 1 gif)

*** This bug has been marked as a duplicate of bug 98500 ***
Comment 2 Buovjaga 2016-12-20 19:56:06 UTC
Not so fast.. as you repro the behavior already in 4.4, it is different from bug 98500.

For me, CPU is not exactly maxed out, but it does double.

Yet, Armin's comments in bug 98500 still hold..

Version: 5.4.0.0.alpha0+
Build ID: 53edf60c4ce6ed32f87471e018878c40b788005a
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-12-18_07:01:05
Locale: fi-FI (fi_FI); Calc: group

Arch Linux 64-bit, KDE Plasma 5
Version: 5.4.0.0.alpha0+
Build ID: db9aec4520766c87a09d4cb0238ed06ebaeaaeeb
CPU Threads: 8; OS Version: Linux 4.8; UI Render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on December 18th 2016
Comment 3 Telesto 2017-05-24 10:40:33 UTC
Also found in
LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4

Not sure how useful this report is anyhow. There is no actual problem here and the CPU part is already (indirectly) covered by different bug reports.