Bug 104798 - Autocorrect cannot be set to two (or more) languages in one document (Options and Localized options)
Summary: Autocorrect cannot be set to two (or more) languages in one document (Options...
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Linguistic (show other bugs)
Version:
(earliest affected)
5.2.3.3 release
Hardware: x86 (IA32) All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Options-Dialog AutoCorrect-Complete
  Show dependency treegraph
 
Reported: 2016-12-19 22:44 UTC by Milan
Modified: 2021-04-17 12:40 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Milan 2016-12-19 22:44:35 UTC
Description:
In the AutoCorrect in Options cannot been set a language different from Locale Settings (Tools -> Options -> Language Settings -> Languages -> Locale Setting), therefore English/Czech quotes (which are not the same) do not work properly. In the AutoCorrect settings is particular Locale Settings language greyed and cannot be changed.
I have documents with texts in two languages and need the AutoCorrect working correctly in the particular texts and languages by simply putting a cursor in the text.
This bug was confirmed to me by other users of LO too.

Steps to Reproduce:
1. Set language of the Character different from the one set in Locale.
2. Go to Format, AutoCorrect, AutoCorrect Options, Options.
3. The Language is grey and cannot be changed - and doesn't change even if the cursor is placed into a text in different language.

 

Actual Results:  
In the text, AutoCorrect changes quotes according to the locale settings regardless the language set in Character.

Expected Results:
AutoCorrect language should be set simply by putting a cursor in the particular text.


Reproducible: Always

User Profile Reset: Yes.

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/55.0.2883.87 Safari/537.36
Comment 1 Buovjaga 2016-12-31 14:39:00 UTC
As you talk about quotes, I guess you mean Localized options tab specifically.

I confirm the problem.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.2.4.2.0+
Build ID: 5.2.4-1
CPU Threads: 8; OS Version: Linux 4.8; UI Render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Comment 2 QA Administrators 2018-01-04 03:35:33 UTC Comment hidden (obsolete)
Comment 3 Milan 2018-01-31 22:09:56 UTC
The problem was solved partly. The English/Czech quotes now work properly simply by putting a cursor in the particular text.
Nevertheless, a language different from Locale Settings still cannot be set in AutoCorrect Options.
LibreOffice 5.4.4.2 (x64)
Comment 4 QA Administrators 2019-02-01 03:45:56 UTC Comment hidden (obsolete)
Comment 5 QA Administrators 2021-02-01 03:57:19 UTC Comment hidden (obsolete)
Comment 6 Hagar Delest 2021-04-17 09:06:26 UTC
IT would be more user-friendly to allow the language to be changed in that field instead of having to change it in the "Locale setting" field of the Languages options.

This would allow user to quickly check the configuration of the quotes replacement.
Comment 7 Mike Kaganski 2021-04-17 11:52:59 UTC
I'm afraid there's some misconception here. The setting works in multi-lingual document as intended (almost - see tdf#139741), but depends on the text language, which on Windows by default follows system input language, but on other systems does not (see tdf#108151).
Comment 8 Buovjaga 2021-04-17 12:40:25 UTC
Ok, let's close