Download it now!
Bug 104817 - Procdump when opening ODT in 5.4+ and when comparing documents with 5.3 and 5.4+ (see comment 6)
Summary: Procdump when opening ODT in 5.4+ and when comparing documents with 5.3 and 5...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.0.0.alpha0+
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace
Depends on:
Blocks:
 
Reported: 2016-12-20 17:55 UTC by Timur
Modified: 2017-05-04 09:45 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
dump with procdump from compare.txt (11.41 KB, text/plain)
2016-12-22 10:16 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Timur 2016-12-20 17:55:54 UTC
Description:
Testing Bug 98868, looks like there's a ODT fileopen regression. 

Steps to Reproduce:
1. open https://wiki.documentfoundation.org/images/f/f3/GS50-GettingStartedLO.odt
2. (optionally for dump) follow https://bugs.documentfoundation.org/show_bug.cgi?id=98868#c0

Actual Results:  
Fileopen slow with 5.4+. 
(optionally) "Record" and "Compare" with https://wiki.documentfoundation.org/images/f/f3/GS50-GettingStartedLO.odt results with dump in Windows with procdump. 

Expected Results:
Normal, as before up to LO 5.3


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0
Comment 1 Telesto 2016-12-20 19:33:02 UTC
No repro (file opens in around 3/4 seconds)
Version: 5.4.0.0.alpha0+
Build ID: 53edf60c4ce6ed32f87471e018878c40b788005a
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-12-18_06:57:59
Locale: nl-NL (nl_NL); Calc: CL
Comment 2 Xisco Faulí 2016-12-21 15:03:34 UTC
I can't reproduce it in

Version: 5.4.0.0.alpha0+
Build ID: 5a20df55ff829978c880b22e0a1f32c35d0ba30f
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk2; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

file opens in 3/4 seconds
Comment 3 tommy27 2016-12-21 21:48:01 UTC
tested under Win8.1 x64
I see no performance difference between LibO 5.2.3.3 and 5.4.0.0.alpha0+

Build ID: 9cfb2f2f03b5ec086487fd483298466db0b09010
CPU Threads: 4; OS Version: Windows 6.29; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-12-20_23:58:02
Locale: it-IT (it_IT); Calc: group

@Timur
would you please retest with the latest daily?
Comment 4 Timur 2016-12-22 10:16:28 UTC
Created attachment 129862 [details]
dump with procdump from compare.txt

SLOW FILEOPEN
As written in https://bugs.documentfoundation.org/show_bug.cgi?id=98868#c7, I tested with LO 5.4.0.0.alpha0+ Build ID: 5903235d57acb13d9d5286d23b443a01aeab9a3c Windows 6.1 TinderBox: Win-x86@39, Branch:master, Time: 2016-12-19_00:12:28 
It takes 3 minutes for me.

I also tested with LO 5.4.0.0.alpha0+ Build ID: c9303b98ad69213fe346d0657a8bca5ac8fa3bd7 Windows 6.1; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-12-21_23:25:19
It's OK with that one. 

So, I guess fileopen issue is resolved.

COMPARE DUMP
Here is attached dump created with procdump from Edit-compare, as explained. 
Please test this, and if confirmed, bug should be renamed to, let's say, "DUMP on ODT files compare".
Comment 5 Buovjaga 2017-01-23 12:49:40 UTC
Yep, the slowness is only with the debug build. Debug builds are known to affect performance in weird ways, so the issue should be ignored.

I repro procdump with kompi's steps

1. download full getting started guide 4.2 and 5.0 from 
https://wiki.documentfoundation.org/images/0/0f/GS42-GettingStartedLO.odt
and
https://wiki.documentfoundation.org/images/f/f3/GS50-GettingStartedLO.odt
2. open GS Guide 5.0 in LO
3. select menu Edit - Track Changes - Compare Document
4. select GS Guide 4.2 and wait

Version: 5.4.0.0.alpha0+
Build ID: 1c27286b9d5331634c073cd3e327bd941e61bbb6
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2017-01-23_03:24:17
Locale: fi-FI (fi_FI); Calc: group
Comment 6 Timur 2017-02-27 14:03:28 UTC
With master~2017-02-20_05.58.54_LibreOfficeDev_5.4.0.0.alpha0_Win_x86 I get procdump on fileopen. 
Then, both with 5.4+ and 5.3.0.3 I get procdump on file compare per Comment 5.
Comment 7 Timur 2017-05-04 09:45:11 UTC
No repro now with 5.3.2 or 5.4+.
Bug 98202 still reproduced.