Bug 104883 - It is not allowed to install fonts on request
Summary: It is not allowed to install fonts on request
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All Linux (All)
: medium normal
Assignee: Samuel Mehrbrodt (CIB)
QA Contact:
URL:
Whiteboard: target:6.0.0 target:5.4.1 target:5.3.6
Keywords:
: 106536 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-12-23 13:27 UTC by Josemi
Modified: 2017-07-17 07:44 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Image that shows the message which appears when you open the cells format (13.83 KB, image/png)
2016-12-23 13:27 UTC, Josemi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Josemi 2016-12-23 13:27:40 UTC
Created attachment 129895 [details]
Image that shows the message which appears when you open the cells format

Over any cell, when you click on Format -> Cells... After few seconds appear This message: "It is not allowed to install fonts on request" followed by "Automatic detection and installation of missing fonts is currently not allowed".

The message only have the button of "Close", and after click on close button, you must wait for long seconds before you can continue working.

This message only appears the first time. Once the message is closed, it doesn't appear anymore into the current book. If you open a new book, we find the same situation: the program blocked by this message.
Comment 1 Adolfo Jayme 2016-12-27 03:29:44 UTC
I don’t think that error message comes from LibreOffice, though… 🤔

What is your Linux distro? Are you using an admin or standard user account? Does this error happen with an existing spreadsheet file or with new files as well?
Comment 2 Josemi 2016-12-29 19:31:56 UTC
My Linux distro is Ubuntu 14.04 and the error happen using an admin
account, but not a root user.

The error always happen with new files the first time you click on "cell
format".

I have 22 computers on my classroom and this error happen in all computers
when into Libreoffice calc somebody click on "cell format".

Thank you for your help. I'm desesperate.
Comment 3 Buovjaga 2016-12-31 20:47:22 UTC
http://askubuntu.com/questions/832857/installing-fonts-on-request-isnt-supported-error-message
Does the advice help?
The error is definitely coming from Ubuntu.
Comment 4 Josemi 2017-01-02 17:18:07 UTC
I Followed the instructions that shows the advice, but I'm in the same situation.
The document wasn't created with windows and when I try to execute the command:

sudo apt-get install ttf-mscorefonts-installer

the system shows the message: "ttf-mscorefonts-installer is already in its most recent version".

I don't know what to do. Do you need more information?

Thank you.
Comment 5 Buovjaga 2017-01-02 17:41:25 UTC
I think you should open a bug at https://bugs.launchpad.net/ubuntu/

Maybe also try with Ubuntu 16.04 on a test machine that matches the ones in your classroom.
Comment 6 andis.lazdins 2017-02-12 08:27:22 UTC
I have the same problem with Libreoffice and it is appears also in Writer. I have Ubuntu 16.04.1 64 bit. I installed ttf-mscorefonts-installer. It's a bit tricky, because the version provided in Ubuntu repositories do not work, but there are plenty of instructions in the internet, how to deal with that. But the problem is still there.
I take a look in Advanced configuration of Libreoffice, what kind of fonts are mentioned in configuration and there are, for instance, Albany fonts, which are not anymore delivered with Libreoffice and probably some other outdated fonts not available with Ubuntu or Libreoffice. I don't know if this could be the reason for error message. But it is really annoying, because it can take up to few minutes when everything is frozen.
Comment 7 Buovjaga 2017-02-12 08:47:34 UTC
Andis: would you like to create the report against Ubuntu? The original reporter has not done it for some reason and it would be good to know it exists, so we can close this.
Comment 8 andis.lazdins 2017-02-12 12:30:24 UTC
(In reply to Buovjaga from comment #7)
> Andis: would you like to create the report against Ubuntu? The original
> reporter has not done it for some reason and it would be good to know it
> exists, so we can close this.

The problem with ttf-mscorefonts-installer is already reported in Ubuntu and temporal workaround provided, however it is not helping with the issue in Libreoffice. Besides Ubuntu most probably will reject report, because I'm not using version provided in Ubuntu repositories, but the version from Libreoffice website.
However, I can try, but I need help with formulation of the problem so that it is not rejected.
Comment 9 Buovjaga 2017-02-12 12:39:04 UTC
(In reply to andis.lazdins from comment #8)
> The problem with ttf-mscorefonts-installer is already reported in Ubuntu and
> temporal workaround provided, however it is not helping with the issue in
> Libreoffice. Besides Ubuntu most probably will reject report, because I'm
> not using version provided in Ubuntu repositories, but the version from
> Libreoffice website.
> However, I can try, but I need help with formulation of the problem so that
> it is not rejected.

Please give a link to the Launchpad report.
Comment 10 andis.lazdins 2017-02-12 13:40:19 UTC
(In reply to Buovjaga from comment #9)

> 
> Please give a link to the Launchpad report.

https://bugs.launchpad.net/ubuntu/+source/msttcorefonts/+bug/1647969
https://bugs.launchpad.net/ubuntu/+source/msttcorefonts/+bug/1607535
Comment 11 Buovjaga 2017-02-12 13:51:04 UTC
Let's phone Björn and ask his opinion.
Comment 12 Björn Michaelsen 2017-02-12 14:18:58 UTC
(In reply to andis.lazdins from comment #10)
> https://bugs.launchpad.net/ubuntu/+source/msttcorefonts/+bug/1647969
That is a dupe of https://bugs.launchpad.net/ubuntu/+source/apt/+bug/1651923

> https://bugs.launchpad.net/ubuntu/+source/msttcorefonts/+bug/1607535

Both of these launchpad bugs are fixed.

> because I'm not using version provided in Ubuntu repositories, but the version from Libreoffice website

Right, if you want system integration you should use the Ubuntu packaged version. System-integration is a doomed effort with a "generic build" like the binaries provided by TDF.
Comment 13 Buovjaga 2017-02-12 14:41:26 UTC
Ok, let's close.
Comment 14 Buovjaga 2017-03-16 08:12:04 UTC
*** Bug 106536 has been marked as a duplicate of this bug. ***
Comment 15 Samuel Mehrbrodt (CIB) 2017-07-13 07:06:14 UTC
(In reply to Björn Michaelsen from comment #12)
> (In reply to andis.lazdins from comment #10)
> > https://bugs.launchpad.net/ubuntu/+source/msttcorefonts/+bug/1647969
> That is a dupe of https://bugs.launchpad.net/ubuntu/+source/apt/+bug/1651923
> 
> > https://bugs.launchpad.net/ubuntu/+source/msttcorefonts/+bug/1607535
> 
> Both of these launchpad bugs are fixed.

I investigated this a bit more and it seems the problem is something else.
LibreOffice calls PackageKit via dbus and Ubuntu shows an error message because it doesn't support the InstallFontconfigResources method: http://bazaar.launchpad.net/~aptdaemon-developers/sessioninstaller/main/view/head:/sessioninstaller/core.py#L1134

Ideally this should be fixed in the sessioninstaller, but for now we can at least work around the problem by not calling that method any longer if we detect it's broken.
Comment 16 Commit Notification 2017-07-13 14:27:11 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e8567ecd9d78a742cbab86498f7a31b22ee92ffa

tdf#104883 Don't call InstallFontconfigResources if it's not available

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Commit Notification 2017-07-14 23:12:30 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=aa00f568a699dd00e2a29cb0d5c0fb1122b82f61&h=libreoffice-5-4

tdf#104883 Don't call InstallFontconfigResources if it's not available

It will be available in 5.4.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Commit Notification 2017-07-16 15:36:33 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f86d9d732d9b2aa711d321a8c9f4110b638560b4&h=libreoffice-5-3

tdf#104883 Don't call InstallFontconfigResources if it's not available

It will be available in 5.3.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 19 Samuel Mehrbrodt (CIB) 2017-07-17 07:44:28 UTC
The dialog should now show up only one time.

You can prevent it from showing up at all by setting the config option "PackageKit::EnableFontInstallation" to "false".