Bug 104914 - 5.3RC1: "Toolbar Layout" submenu items not localizable
Summary: 5.3RC1: "Toolbar Layout" submenu items not localizable
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.3.0.0.beta2
Hardware: All macOS (All)
: medium normal
Assignee: Andras Timar
URL:
Whiteboard: target:5.4.0 target:5.3.0.2
Keywords:
Depends on:
Blocks:
 
Reported: 2016-12-24 21:58 UTC by Martin Srebotnjak
Modified: 2016-12-27 09:56 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Unlocalizable items (73.77 KB, image/png)
2016-12-24 22:46 UTC, Martin Srebotnjak
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Srebotnjak 2016-12-24 21:58:24 UTC
Description:
None of the "Toolbar Layout" submenu (in View menu) items seem to be localizable.
Using both fully localized 5.3b2 and 5.3rc1 in Slovenian and those items appear in English.

Steps to Reproduce:
1. Open LO, then a Writer document (existing or new).
2. Select View - Toolbar Layout - see all the submenu items
3.

Actual Results:  
The Toolbar Layout submenu lists items in English: Default, Single toolbar, Sidebar, Notebookbar (although the UI is 100 % localized in Slovenian).


Expected Results:
These menu subitems should be localizable.


Reproducible: Always

User Profile Reset: No

Additional Info:
Since this will be a very looked into feature (the notebook bar, that is) I think it is priority to make it also fully localizable.


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:50.0) Gecko/20100101 Firefox/50.0
Comment 1 Martin Srebotnjak 2016-12-24 22:46:07 UTC
Created attachment 129929 [details]
Unlocalizable items
Comment 2 Andras Timar 2016-12-25 08:50:08 UTC
I pushed a patch to gerrit.
New pots: http://dev-www.libreoffice.org/l10n/latest-pot/libreoffice-5.3-en-US-2016-12-25.pot.zip
Comment 3 Commit Notification 2016-12-25 11:22:45 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=74fdcfdfd30460f6e15461ed94ff7b14f6d432b3

tdf#104914 make 'Toolbar Layout' submenu items localizable

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2016-12-26 23:45:20 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=90864f48a7a69c7eb5e8a245985bef2f33877b0e&h=libreoffice-5-3

tdf#104914 make 'Toolbar Layout' submenu items localizable

It will be available in 5.3.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.