Bug 104924 - Crash in StarBASIC destructor
Summary: Crash in StarBASIC destructor
Status: RESOLVED DUPLICATE of bug 104969
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
5.2.4.1 rc
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace, possibleRegression
Depends on:
Blocks:
 
Reported: 2016-12-25 20:17 UTC by JoNi
Modified: 2017-05-02 14:12 UTC (History)
0 users

See Also:
Crash report or crash signature: ["StarBASIC::`vector deleting destructor'(unsigned int)"]
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description JoNi 2016-12-25 20:17:37 UTC
2 new crash signatures in 5.2.4.1 and 5.2.4.2
http://crashreport.libreoffice.org/stats/signature/StarBASIC::%60vector%20deleting%20destructor'(unsigned%20int)#summary
http://crashreport.libreoffice.org/stats/signature/StarBASIC::~StarBASIC()#summary


there was no change in basic/ since 5.2.3.3
from the backtraces it could be related to
https://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-5-2-4&id=69016f3052dcefa76486d83adbcc6d83df7d674b
   tdf#103852 avoid clipboard deadlock

sadly I have no idea how to reproduce the crash
Comment 1 Markus Mohrhard 2016-12-25 21:28:24 UTC
There are a number of related crashes in calc, impress and writer that all are related to the same commit.

See also the discussion in the ESC minutes mentioning the crash.
Comment 2 JoNi 2017-01-09 14:12:33 UTC
bug was caused by the same commit as bug 104969
guess this is fixed too

*** This bug has been marked as a duplicate of bug 104969 ***