Bug Hunting Session
Bug 104999 - Dialog "scanning" does not work 64-bit Windows builds (now requires TWAIN DSM present on 64-bit systems)
Summary: Dialog "scanning" does not work 64-bit Windows builds (now requires TWAIN DSM...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.1.6.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.3.0
Keywords:
: 105283 105284 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-12-30 11:55 UTC by bodo.gros
Modified: 2017-10-28 18:21 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bodo.gros 2016-12-30 11:55:20 UTC
I use the German version of the menu 

Scanner: HP Officejet 6600


I press menu: Insert>media>scanning> 
and nothing happens... Not scanning

With HP Software it works 

Reproducible: Always
Comment 1 Julien Nabet 2016-12-30 13:58:15 UTC
Reading this https://bugs.documentfoundation.org/show_bug.cgi?id=92478#c31, either you must check you installed LO 32 bits or you must check you got 64bit twain dll.
Comment 2 V Stuart Foote 2016-12-30 16:47:49 UTC
Fixed on 64-bit builds at 5.3.0 with
https://cgit.freedesktop.org/libreoffice/core/commit/?id=3cecadbddd137770552ceaad018336e195233e4a

but is dependent on 64-bit TWAIN DSM and valid data source ".ds" description installed to system by some external action.

SourceForge TWAINDSM.dll can not be directly registered with regsrv32, and the bundled .msm installer module must be parsed.

=-ref-=
https://sourceforge.net/projects/twain-dsm/files/TWAIN%20DSM%202%20Windows%2032%2B64/
Comment 3 Julien Nabet 2017-01-12 13:27:42 UTC
*** Bug 105283 has been marked as a duplicate of this bug. ***
Comment 4 Xisco Faulí 2017-10-28 18:21:05 UTC
*** Bug 105284 has been marked as a duplicate of this bug. ***