Bug 105070 - Libreoffice help indicates wrong location of 'Compare Document' menu item
Summary: Libreoffice help indicates wrong location of 'Compare Document' menu item
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
5.2.4.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Gabor Kelemen
QA Contact:
URL:
Whiteboard: target:5.4.0
Keywords:
Depends on:
Blocks: Help-Menu-Updates
  Show dependency treegraph
 
Reported: 2017-01-03 16:11 UTC by Normand Fortier
Modified: 2017-06-08 11:05 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
LibreOffice help screen capture (135.35 KB, image/png)
2017-01-03 16:13 UTC, Normand Fortier
Details
LibreOffice Edit menu (82.55 KB, image/png)
2017-01-03 16:14 UTC, Normand Fortier
Details
LibreOffice Edit - Trach Changes menu (99.66 KB, image/png)
2017-01-03 16:14 UTC, Normand Fortier
Details
Screenshot LibreOffice Hilfe (257.46 KB, image/jpeg)
2017-01-04 10:45 UTC, Dieter Praas
Details
Screenshot 2 LibreOffice Hilfe (150.28 KB, image/jpeg)
2017-01-04 10:46 UTC, Dieter Praas
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Normand Fortier 2017-01-03 16:11:53 UTC
Description:
Under "Comparing Versions of a Document", LibreOffice help instructs to choose "Edit - Compare Document". There is no such menu item; the "Compare Document" is in fact under "Edit - Track Changes - Compare Document".
This may not sound like much but as it was the first time I was using this feature, it took me quite a while to figure out that the help was wrong.
Please correct help documentation (and translations of course).

Actual Results:  
See above.

Expected Results:
Help should indicate correct information, see above.


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:50.0) Gecko/20100101 Firefox/50.0
Comment 1 Normand Fortier 2017-01-03 16:13:46 UTC
Created attachment 130113 [details]
LibreOffice help screen capture
Comment 2 Normand Fortier 2017-01-03 16:14:20 UTC
Created attachment 130114 [details]
LibreOffice Edit menu
Comment 3 Normand Fortier 2017-01-03 16:14:59 UTC
Created attachment 130115 [details]
LibreOffice Edit - Trach Changes menu
Comment 4 Dieter Praas 2017-01-04 10:45:12 UTC
Created attachment 130146 [details]
Screenshot LibreOffice Hilfe

I can confirm it with LO 5.2.4.2 and germen UI.
Comment 5 Dieter Praas 2017-01-04 10:46:36 UTC
Created attachment 130147 [details]
Screenshot 2 LibreOffice Hilfe
Comment 6 Commit Notification 2017-01-08 21:57:28 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=5e4b205a3259f265e6dddc578d16793c1a733e9e

tdf#105070 'Compare Document' menu item has moved
Comment 7 Gabor Kelemen 2017-01-08 22:25:25 UTC
Thanks for the detailed report, it really helped to fix this problem quickly.
Comment 8 skierpage 2017-06-06 21:48:01 UTC
This is not fixed in the web site help, which is what I get if I choose Help > LibreOffice Help.  https://help.libreoffice.org/Common/Comparing_Versions_of_a_Document still says to choose Edit - Compare Document. From the page's version history it doesn't look like this fix has been made yet.

https://wiki.documentfoundation.org/Development/Wikihelp describes a plan to create wiki pages from git, but doesn't explain how it currently works.
Comment 9 Buovjaga 2017-06-08 11:05:46 UTC
(In reply to skierpage from comment #8)
> This is not fixed in the web site help, which is what I get if I choose Help
> > LibreOffice Help. 
> https://help.libreoffice.org/Common/Comparing_Versions_of_a_Document still
> says to choose Edit - Compare Document. From the page's version history it
> doesn't look like this fix has been made yet.
> 
> https://wiki.documentfoundation.org/Development/Wikihelp describes a plan to
> create wiki pages from git, but doesn't explain how it currently works.

I'm guessing it's because the commit targets 5.4, which is not out yet. So let's keep it closed until 5.4 happens.