Download it now!
Bug 105178 - Latin text shifts to the left in vertical mode for certain fonts
Summary: Latin text shifts to the left in vertical mode for certain fonts
Status: RESOLVED DUPLICATE of bug 111967
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.3.0.0.beta2
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: HarfBuzz-regressions Vertical-Text
  Show dependency treegraph
 
Reported: 2017-01-07 16:31 UTC by Volga
Modified: 2017-12-08 21:14 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Test file (9.75 KB, application/vnd.oasis.opendocument.text)
2017-01-07 16:37 UTC, Volga
Details
Screenshot (45.30 KB, image/png)
2017-01-07 16:39 UTC, Volga
Details
2nd screenshot (44.69 KB, image/png)
2017-01-07 16:51 UTC, Volga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Volga 2017-01-07 16:31:54 UTC
Description:
LibreOffice fixed a bug for vertical layout between Latin and Chinese characters (bug 103784), but unhappy with certain fonts.

Steps to Reproduce:
1. Input texts in two frames with vertical writing.
2. One frame use the same font for Western Text Font and Asian Text Font, other frame specify a CJK font for Asian Text Font.

Actual Results:  
If I use same font for Western Text Font and Asian Text Font, then I found Latin text shifts to the left, tested with Linux Libertine G, Linux Bionium G, Liberation fonts and others. If I use western font for Western Text Font and CJK font Asian Text Font, then I proper effect. 

Expected Results:
Both Latin and CJK texts should get proper text alignments in vertical writing, not be affected by font families.


Reproducible: Always

User Profile Reset: No

Additional Info:
Version: 5.3.0.0.beta2+ (x64)
Build ID: 371f0f6770add78ae81e0f769d0490874bca353c
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; Layout Engine: new; 
TinderBox: Win-x86_64@62-TDF, Branch:libreoffice-5-3, Time: 2016-12-22_13:59:31
Locale: zh-CN (zh_CN); Calc: group


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:50.0) Gecko/20100101 Firefox/50.0
Comment 1 Volga 2017-01-07 16:37:56 UTC
Created attachment 130243 [details]
Test file
Comment 2 Volga 2017-01-07 16:39:35 UTC
Created attachment 130244 [details]
Screenshot
Comment 3 Volga 2017-01-07 16:51:17 UTC
Created attachment 130245 [details]
2nd screenshot

This bug also affect I.Ming (https://github.com/ichitenfont/I.Ming), but the result looks differernt. Latin characters always shifted to the left.
Comment 4 Buovjaga 2017-01-13 16:26:42 UTC
Confirmed.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.4.0.0.alpha0+
Build ID: 57779b5f3a49fedd952aed70ddcce22f48b98ea5
CPU Threads: 8; OS Version: Linux 4.8; UI Render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on January 13th 2016
Comment 5 Volga 2017-03-17 08:22:19 UTC Comment hidden (obsolete)
Comment 6 Volga 2017-03-26 14:24:33 UTC Comment hidden (obsolete)
Comment 7 Volga 2017-06-08 04:40:29 UTC
(In reply to Volga from comment #0)
> Expected Results:
> Both Latin and CJK texts should get proper text alignments in vertical
> writing, not be affected by font families.
To get the expected results, we need get the left edge of upright glyphs, then making them aligned with descenders.
Comment 8 Mark Hung 2017-12-08 21:14:35 UTC

*** This bug has been marked as a duplicate of bug 111967 ***