Bug 105195 - query result column alias does not work
Summary: query result column alias does not work
Status: RESOLVED DUPLICATE of bug 70506
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
5.3.0.0.beta2
Hardware: All All
: medium normal
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-01-08 18:55 UTC by Drew Jensen
Modified: 2017-01-09 11:29 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
Screenshots of example queries (68.87 KB, image/jpeg)
2017-01-08 18:55 UTC, Drew Jensen
Details
example odb (3.37 KB, application/vnd.oasis.opendocument.database)
2017-01-08 18:56 UTC, Drew Jensen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Drew Jensen 2017-01-08 18:55:28 UTC
Created attachment 130263 [details]
Screenshots of example queries

Using the Libreoffice 5.3 beta2 build for Linux
Base query component does not honor column alias
Checked with 'SQL Direct' disabled and enabled
Results in screenshot file attached
Example database firebird embedded DB query1  and query2 (sql direct enabled) attached
Comment 1 Drew Jensen 2017-01-08 18:56:14 UTC
Created attachment 130264 [details]
example odb
Comment 2 robert 2017-01-09 11:29:48 UTC
Is a duplicate of bug70506.
Fixed in 5.3.0.1.
Also fixed in 5.4.0.0alpha0

*** This bug has been marked as a duplicate of bug 70506 ***