Bug 105254 - Pivot table Filter field is lost if saved in Microsoft 2007-2013 XML file format, but if saved from ODF then whole pivot table is lost
Summary: Pivot table Filter field is lost if saved in Microsoft 2007-2013 XML file for...
Status: RESOLVED DUPLICATE of bug 121612
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.7.2 release
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: dataLoss, filter:xlsx
Depends on:
Blocks: Pivot-Table-XLSX
  Show dependency treegraph
 
Reported: 2017-01-11 13:15 UTC by grofaty
Modified: 2019-02-07 12:23 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample_steps_from_1-12 (8.56 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2017-01-12 05:55 UTC, grofaty
Details
Sample_steps_from_13-16 (11.41 KB, application/vnd.oasis.opendocument.spreadsheet)
2017-01-12 05:56 UTC, grofaty
Details
Sample_steps_from_17-20 (5.96 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2017-01-12 05:56 UTC, grofaty
Details
2003_document_filter_dialog_no_blue_color.png (59.57 KB, image/png)
2019-02-07 08:58 UTC, grofaty
Details

Note You need to log in before you can comment on or make changes to this bug.
Description grofaty 2017-01-11 13:15:10 UTC
Test 1 - Pivot table Filter problem
1. Open LibreOffice Calc.
2. In fields type in:
A1: Name
A2: Alice
A3: Bob
A4: Connie
B1: Size
B2: 170
B3: 180
B4: 160
3. Select fields from A1:B4.
4. Tools | Pivot Data | Pivot Data.
5. On "Select Source" leave default and click on OK button.
6. "Pivot Table Layout" dialog opens. From "Available Fields" drag Name field to "Rows Fields".
7. From "Available Fields" drag Size field to "Data Fields" and click on OK button.
8. Right mouse click somewhere on displayed pivot table and select Filter.
9. Filter dialog opens. In first drop-down row select "Field name" to Name, Condition select "=" and Value select Alice.
10. File | Save and select "Save as type": "Microsoft Excel 2007-2013 XML" format and confirm.
11. Close document.
12. Open saved document. Problem appears. Filter (step 8) is lost.

Test 2 - Works fine
13. In opened document add filter (step 8).
14. File | Save a Copy and select data type "ODF Spreadsheet".
15. Close all files.
16. Open from step 13 saved document and filter is preserved. Works as expected.

Test 3 - Pivot table is lost
17. File | Save a Copy and save file to "Microsoft Excel 207-2013 XML" format.
18. Close all files.
19. Open in step 14 saved document.
20. Pivot table is lost. Instead of pivot table ordinary table data are displayed.

Tested on Windows 7 SP1.

==== Help | About ================
Version: 5.2.4.2
Build ID: 3d5603e1122f0f102b62521720ab13a38a4e0eb0
CPU Threads: 3; OS Version: Windows 6.1; UI Render: default; 
Locale: sl-SI (sl_SI); Calc: group
==================================
Comment 1 Xisco Faulí 2017-01-11 20:36:50 UTC
Hello

Thank you for reporting the bug. Please attach a sample document, as this makes it easier for us to verify the bug. 
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the requested document is provided.
(Please note that the attachment will be public, remove any sensitive information before attaching it. 
See https://wiki.documentfoundation.org/QA/FAQ#How_can_I_eliminate_confidential_data_from_a_sample_document.3F for help on how to do so.)
Comment 2 grofaty 2017-01-12 05:55:56 UTC
Created attachment 130335 [details]
Sample_steps_from_1-12
Comment 3 grofaty 2017-01-12 05:56:23 UTC
Created attachment 130336 [details]
Sample_steps_from_13-16
Comment 4 grofaty 2017-01-12 05:56:38 UTC
Created attachment 130337 [details]
Sample_steps_from_17-20
Comment 5 grofaty 2017-01-12 05:57:12 UTC
Hi,
I have created three documents for each of the test one document. I think it may even be two separate problems in this pivot table - one for test 1 and another for test 2.

By the way there is little mistake in Description of bug in step 19. Correct description is: "Open in step 17 saved document."
Regards
Comment 6 grofaty 2017-01-12 07:01:29 UTC
I was trying to recreate a problem on master on Windows 7, but master crashes. I have reported new bug 105273 for crash.

I was trying to recreate a problem on LO 5.2.4.2 on Ubuntu 16.04, but there is no Data | Pivot Table | Pivot Table option available. I have reported a new bug 105275.
Comment 7 Buovjaga 2017-01-13 19:55:40 UTC
(In reply to grofaty from comment #2)
> Created attachment 130335 [details]
> Sample_steps_from_1-12

Repro the losing of the pivot after save to ods + save to xlsx.
If you happen to click the Name filter once after saving to ods and reloading, then the xlsx will be fine (even though your Size filter is lost).

Clicking the Name filter restores the missing dropdown triangle. In 3.6, this triangle is not lost, but the pivot table data is still lost after saving to xlsx.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.4.0.0.alpha0+
Build ID: 57779b5f3a49fedd952aed70ddcce22f48b98ea5
CPU Threads: 8; OS Version: Linux 4.8; UI Render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on January 13th 2016

Arch Linux 64-bit
Version 3.6.7.2 (Build ID: e183d5b)
Comment 8 grofaty 2017-08-03 11:12:00 UTC
Tested on 5.4.0 and problem is exactly the same as in previous versions.


Help | About:

Version: 5.4.0.3
Build ID: 7556cbc6811c9d992f4064ab9287069087d7f62c
CPU threads: 3; OS: Windows 6.1; UI render: default;
Locale: sl-SI (sl_SI); Calc: group
Comment 9 grofaty 2018-02-06 14:05:17 UTC
I have retested on LibreOffice 6.0.0.3 on Windows 7 and
Test 1: Fixed! Excellent. Thanks a lot.
Test 2: Still working _fine_.
Test 3: Problem persists.


Help | About:

Version: 6.0.0.3 (x64)
Build ID: 64a0f66915f38c6217de274f0aa8e15618924765
CPU threads: 3; OS: Windows 6.1; UI render: default; 
Locale: sl-SI (sl_SI); Calc: group
Comment 10 grofaty 2018-02-07 06:56:39 UTC
Just to complete the test I have downloaded nightly version on Windows 7 and retested. Result is exactly the same as in v6.0.0.3 above.

Help | About

Version: 6.1.0.0.alpha0+
Build ID: f0c171a1dd2698f5bec14f5cf00136477032c202
CPU threads: 3; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-02-07_01:08:46
Locale: sl-SI (sl_SI); Calc: group
Comment 11 grofaty 2018-11-07 07:25:29 UTC
I have retested this problem, because Microsoft Office user gets broken document.

From my first post:
Test1: Works fine.
Test2: Works fine.
Test3: Problem still persists. In Excel file pivot table is lost.

Tested on Windows 7 SP1 with latest stable and also with latest nightly.

==== Help | About ================
Version: 6.1.3.2 (x64)
Build ID: 86daf60bf00efa86ad547e59e09d6bb77c699acb
CPU threads: 3; OS: Windows 6.1; UI render: default; 
Locale: sl-SI (sl_SI); Calc: group threaded
==================================



==== Help | About ================
Version: 6.2.0.0.alpha1+ (x64)
Build ID: 317f5f2323b8ff7948c4812faaeb0c2a3b907ce8
CPU threads: 3; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-11-07_02:31:39
Locale: sl-SI (sl_SI); Calc: threaded
==================================
Comment 12 Buovjaga 2019-02-06 12:34:44 UTC
I re-tested from scratch and confirmed even the third problem is gone. Bubli asked to test, the fix is for bug 121612.

Arch Linux 64-bit
Version: 6.3.0.0.alpha0+
Build ID: 5408f0731b9cd8be0e1b7aa5145b825337baad84
CPU threads: 8; OS: Linux 4.20; UI render: default; VCL: gtk3; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded
Built on 5 February 2019

*** This bug has been marked as a duplicate of bug 121612 ***
Comment 13 grofaty 2019-02-07 08:58:12 UTC
Created attachment 148973 [details]
2003_document_filter_dialog_no_blue_color.png
Comment 14 grofaty 2019-02-07 08:58:53 UTC
Hi,
I retested the problem on master and the "Test 3" is still not fully fixed.
The "blue color and dot" are still not displayed after opening 2003 document.

I have attached 2003_document_filter_dialog_no_blue_color.png in previous post. It is a picture to fully explain the problem.

I also see this bug report is not exact duplicate of bug 121612. Duplicate is only Test-1, but Test-3 is not in the "duplicate bug" report.
Please unmark the duplication.

Regards

=== Help | About ===
Version: 6.3.0.0.alpha0+
Build ID: 82fb7f9f90a3ba9d53b3412124e513aa78ddca10
CPU threads: 3; OS: Windows 6.1; UI render: default; VCL: win; 
Locale: sl-SI (sl_SI); UI-Language: en-US
Calc: threaded
===================
Comment 15 Buovjaga 2019-02-07 10:54:34 UTC
(In reply to grofaty from comment #14)
> Hi,
> I retested the problem on master and the "Test 3" is still not fully fixed.
> The "blue color and dot" are still not displayed after opening 2003 document.
> 
> I have attached 2003_document_filter_dialog_no_blue_color.png in previous
> post. It is a picture to fully explain the problem.
> 
> I also see this bug report is not exact duplicate of bug 121612. Duplicate
> is only Test-1, but Test-3 is not in the "duplicate bug" report.
> Please unmark the duplication.

I got the blue color and dot, so my result is different. Just to be clear: you retested from step 1 and did not use the existing attachments? If yes, I may have to test on Windows to see, if it differs from Linux.

But really, now we are talking about a different bug, which should go into a new report (if it is real).
Comment 16 grofaty 2019-02-07 12:23:45 UTC
Buovjaga,
I have manually followed from steps. I haven't used documents.

OK, I agree this should probably be a new bug report. I will try to find simpler steps to reproduce and report separate bug.

I am marking bug status back to previous state.

*** This bug has been marked as a duplicate of bug 121612 ***