Bug Hunting Session
Bug 105330 - The text cursor will disappear when undoing creating a table in a table (nested)
Summary: The text cursor will disappear when undoing creating a table in a table (nested)
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.0.4 release
Hardware: All All
: medium minor
Assignee: Miklos Vajna
URL:
Whiteboard: target:6.4.0 target:6.3.3
Keywords: bibisected, regression
: 116144 (view as bug list)
Depends on:
Blocks: Writer-Tables Undo-Redo Text-Cursor
  Show dependency treegraph
 
Reported: 2017-01-14 08:54 UTC by Telesto
Modified: 2019-09-18 11:37 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file (8.76 KB, application/3dr)
2017-01-14 08:55 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2017-01-14 08:54:56 UTC
Description:
The text position pointer (I-beam pointer) will disappear when undoing creating a table in a table

Steps to Reproduce:
1.Open attached file
2. Insert a table in A1 (dimensions don't matter)
3. Undo it (press CTRL+Z
4. The text position pointer disappear in the cell which did contain the inserted table. Exiting the table cell and returning won't help. Only typing some text will make it reappear


Actual Results:  
The text position pointer disappear in the cell which did contain the inserted table.

Expected Results:
The text pointer shouldn't disappear


Reproducible: Always

User Profile Reset: No

Additional Info:
Found in
Version: 5.4.0.0.alpha0+
Build ID: 88f561204d7cee25633df8117cc8d7e1ebd8e9ad
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-01-11_23:07:37
Locale: nl-NL (nl_NL); Calc: CL

and in
Versie 4.0.0.3 (Bouw-id: 7545bee9c2a0782548772a21bc84a9dcc583b89)

but not in
LibreOffice 3.5.7.2
Build ID: 3215f89-f603614-ab984f2-7348103-1225a5b


User-Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Comment 1 Telesto 2017-01-14 08:55:18 UTC
Created attachment 130417 [details]
Example file
Comment 2 Telesto 2017-01-24 17:02:34 UTC

*** This bug has been marked as a duplicate of bug 89770 ***
Comment 3 Dieter Praas 2018-03-03 08:21:46 UTC
Still present in

Version: 6.1.0.0.alpha0+ (x64)
Build ID: d64ce643275e0b2b0dea9e532fc261391dc8793c
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-03-01_03:24:30
Locale: de-DE (de_DE); Calc: CL
Comment 4 Dieter Praas 2018-03-03 08:23:07 UTC
*** Bug 116144 has been marked as a duplicate of this bug. ***
Comment 5 Buovjaga 2018-07-01 16:58:27 UTC
Bibisected on Linux with 43all to range https://cgit.freedesktop.org/libreoffice/core/log/?qt=range&q=0bbf79005a697c6781047c01f05eb660836a18e1...61d78aca81f08ac3a0f9eb65799d04d56fbad312

This looks likely: https://cgit.freedesktop.org/libreoffice/core/commit/?id=e4509eea8fc7c07ddff48edf0d4c015c2663d896
n#751313 SwCallLink: avoid redrawing complete rows without nested tables

Adding Cc: to Miklos Vajna
Comment 6 Commit Notification 2019-09-17 06:58:01 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/c56bf1479cc71d1a2b0639f6383e90c1f7e3655b%5E%21

tdf#105330 sw: fix lost cursor on undoing nested table insert

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2019-09-17 16:58:49 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/+/d5b50e74ee822e1c8402e3044e14799e47907ff8%5E%21

tdf#105330 sw: fix lost cursor on undoing nested table insert

It will be available in 6.3.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Xisco Faulí 2019-09-18 11:37:56 UTC
Verified in

Version: 6.4.0.0.alpha0+
Build ID: 938d304f0f28962594853a8db1cc574abff8dc49
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Miklos, thanks for fixing this issue!