Download it now!
Bug 105338 - Give warning, if you install 32-bit help on installed 64-bit LO and vice-versa
Summary: Give warning, if you install 32-bit help on installed 64-bit LO and vice-versa
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
5.2.4.2 release
Hardware: All Windows (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsDevAdvice
Depends on:
Blocks: Help Installer-Windows
  Show dependency treegraph
 
Reported: 2017-01-14 15:31 UTC by sfmaster
Modified: 2018-07-28 11:52 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sfmaster 2017-01-14 15:31:29 UTC
Description:
Last week, I downloaded the latest version of LO along with the Help file, and the necessary JRE, and Java 64 bit (Java 32 has not been updated since last year).
Since that time, I cannot get Help to work offline - I went to the Language screen according to one post.
Can't you post a fix or instructions to correct this problem - and in future, include the HELP file as part of the main program d/l in one package.
Thank you!

Actual Results:  
tried to use help

Expected Results:
no change


Reproducible: Always

User Profile Reset: no

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/55.0.2883.87 Safari/537.36
Comment 1 V Stuart Foote 2017-01-14 17:44:50 UTC
Please provide OS details and clip text for the build from Help -> About LibreOffice

Also, post the name of the installation file you'd downloaded for the LibreOffice install and the Off-line Help install.  And if you have the means please calculate and post the MD5 or SHA-256 hash value for both installers.

Thanks.
Comment 2 Dieter 2017-02-07 14:26:22 UTC
I confirm this problem with LO 5.3.0.3. After installation of the help file (LibreOffice_5.3.0_Win_x86_helppack_de.msi)I couldn't open offline help.

Name of the installation file: LibreOffice_5.3.0_Win_x64

Version: 5.3.0.3 (x64)
Build-ID: 7074905676c47b82bbcfbea1aeefc84afe1c50e1
CPU-Threads: 4; BS-Version: Windows 6.19; UI-Render: GL; Layout-Engine: neu; 
Gebietsschema: de-DE (de_DE); Calc: group
Comment 3 Buovjaga 2017-02-11 20:35:14 UTC
(In reply to dieterp from comment #2)
> I confirm this problem with LO 5.3.0.3. After installation of the help file
> (LibreOffice_5.3.0_Win_x86_helppack_de.msi)I couldn't open offline help.
> 
> Name of the installation file: LibreOffice_5.3.0_Win_x64
> 
> Version: 5.3.0.3 (x64)
> Build-ID: 7074905676c47b82bbcfbea1aeefc84afe1c50e1
> CPU-Threads: 4; BS-Version: Windows 6.19; UI-Render: GL; Layout-Engine: neu; 
> Gebietsschema: de-DE (de_DE); Calc: group

What if you use a help file that matches the 64-bitness of your LibreOffice: http://download.documentfoundation.org/libreoffice/stable/5.3.0/win/x86_64/LibreOffice_5.3.0_Win_x64_helppack_de.msi
Comment 4 Dieter 2017-02-12 16:29:49 UTC
(in reply to Buovjage from comment #3)
I think, you're right. I used the wrong file. Do you think it could be a possible enhancement to give a warning during help-installation if you use the file for 32Bit if you've installed LO for 64Bit?
Comment 5 Buovjaga 2017-03-27 09:19:06 UTC
(In reply to dieterp from comment #4)
> (in reply to Buovjage from comment #3)
> I think, you're right. I used the wrong file. Do you think it could be a
> possible enhancement to give a warning during help-installation if you use
> the file for 32Bit if you've installed LO for 64Bit?

I asked many times on the developer IRC channel, but did not get a reply. Did the problem go away after you installed a 64-bit help file?

What about the original reporter, is everything ok now?
Comment 6 Dieter 2017-03-27 11:16:58 UTC
WORKSFORME
Comment 7 Buovjaga 2017-03-27 19:19:45 UTC
*** Bug 106619 has been marked as a duplicate of this bug. ***
Comment 8 QA Administrators 2017-09-29 08:57:23 UTC Comment hidden (obsolete)
Comment 9 Dieter 2017-09-29 09:15:38 UTC
(In reply to Buovjaga from comment #5)
> (In reply to dieterp from comment #4)
> > (in reply to Buovjage from comment #3)
> > I think, you're right. I used the wrong file. Do you think it could be a
> > possible enhancement to give a warning during help-installation if you use
> > the file for 32Bit if you've installed LO for 64Bit?
> 
> I asked many times on the developer IRC channel, but did not get a reply.
> Did the problem go away after you installed a 64-bit help file?
> 

I changed the summary and added the Keyword needsDevAdvice, so perhaps there will be an answer.