Download it now!
Bug 105374 - Toolbars and UI elements wrong display with KDE
Summary: Toolbars and UI elements wrong display with KDE
Status: RESOLVED DUPLICATE of bug 103676
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.2.4.2 release
Hardware: x86-64 (AMD64) Linux (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-01-16 20:01 UTC by Hamid
Modified: 2017-05-27 18:37 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot showing improper UI render (166.06 KB, image/png)
2017-01-16 20:01 UTC, Hamid
Details
improper rendered sidebar in LO 5.3 (47.57 KB, image/jpeg)
2017-02-09 09:21 UTC, pieter kristensen
Details
black pull-down menu item (66.15 KB, image/jpeg)
2017-02-09 14:22 UTC, pieter kristensen
Details
also with Ubuntu the sidebar can look ugly (253.77 KB, image/png)
2017-03-21 14:13 UTC, pieter kristensen
Details
sidebar late may 2017 newest HWE kernel mesa 17.2 (oibaf ppa) (233.81 KB, image/jpeg)
2017-05-27 18:21 UTC, pieter kristensen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Hamid 2017-01-16 20:01:38 UTC
Created attachment 130482 [details]
Screenshot showing improper UI render

Hello,

Libreoffice UI is not showing right. I have installed libreoffice-gtk3 but to no avail. The screen from writer shows toolbars showing content from the below window superimposed. The active style is displayed foreground on same background color, so it is unreadable unless you click to make it active, then you can read what style it is showing.

I have tried tweaking themes in KDE but again no change.

In Calc the active cell is not displayed.
Comment 1 Xisco Faulí 2017-01-16 20:03:37 UTC Comment hidden (obsolete)
Comment 2 Hamid 2017-01-16 20:24:19 UTC
Reseting the profile didn't improve the situation. The system running is:

KDE Plasma: 5.7.5
KDE Frameworks: 5.26.0
Qt: 5.6.1
Kernel: 4.8.0-34-generic  
OS Type: 64-bit

No processing power and memory limits

It was OK before upgrading to Kubuntu 16.10.
Comment 3 Hamid 2017-01-17 20:45:10 UTC
Managed to put the GTK3 facelift and the symptoms are gone. But the Qt interface is buggy with the toolbars having transparent background.
Comment 4 Buovjaga 2017-01-24 11:06:13 UTC
The sidebar style name as white on white is a known problem (I don't have time to dig it out now).
Otherwise it seems you have some unique glitching going on.

"It was OK before upgrading to Kubuntu 16.10" makes me think you should report this to Kubuntu or try something else to sort it out. I mean, you upgraded and did not reinstall Kubuntu from scratch? And reinstalling LibreOffice does not help?
Comment 5 Hamid 2017-01-25 19:06:27 UTC
The code base is on par with the normal update cycles i.e. whenever new updates appear on the repos it is fetched and applied. I re-instantiated a new local user prefs directory by removing the ~/.config/libreoffice/4/{->user<-} and then enabling GTK3 worked.

16.04 had another issue where tooltips you only could read with your heart cause of same fore/back ground colors. After digging and changing some setting it got back to normal but a minor symptom fired up  elsewhere. Seems something is broken and that comes up with a fresh install. I might give it a try when I find some peace of mind and report the result.
Comment 6 Buovjaga 2017-01-26 06:57:10 UTC
Ok, but did you upgrade from 16.04 to 16.10 or did you do a clean install of 16.10?
Comment 7 Hamid 2017-01-26 14:25:35 UTC
upgrade from 16.04 to 16.10
Comment 8 pieter kristensen 2017-02-09 09:21:26 UTC
Created attachment 131028 [details]
improper rendered sidebar in LO 5.3
Comment 9 pieter kristensen 2017-02-09 09:22:37 UTC
I have these strange things too. Immediately after the system replaced the "old and buggy" xserver-xorg-video-intel graphics driver by the newer xorg-xserver-video-intel-native-modesetting driver, the troubles begun.

I am using kde too. Plasma 5.9.1. on my kde Neon computer.
Yesterday I reinstalled the old video driver and after I did that LibreOffice wouldn't even open anymore. It kept hanging in the new repair-dialog. I am using LibreOffice 5.3 from the LibreOffice ppa.

I tried LO 5.3. on Ubuntu and that went smoothly.
I have more little annoyances. 
When I select tekst in Writer, the selection is not filled with a color, I see only al thin line around the selected tekst. And in calc, when I click on a cell, this cell doesn't get a black line around it to show the focus is there.

I am 100% sure these two things are caused by the new graphics driver too.

After I got this new driver quite a big part of the UI of LO was messed up. It got better after 5.3 was released. But as you see: there are still problems.
Comment 10 Buovjaga 2017-02-09 13:02:59 UTC
Setting to NEW.

Hamid: I guess you are using modesetting driver as well?
Comment 11 pieter kristensen 2017-02-09 14:21:28 UTC
Also recently libreoffice started to render black pull-down menu's when I click on them. When I leave the menu and immediately click again it is ok. I am convinced that this is also due to the new native-modesetting driver.
Added attachment
Comment 12 pieter kristensen 2017-02-09 14:22:21 UTC
Created attachment 131041 [details]
black pull-down menu item
Comment 13 Hamid 2017-02-09 17:04:05 UTC
How to check for the driver? This is how far I got in few minutes:

$lshw -C display
…
configuration: driver=i915 latency=0
…

LO info:
Version: 5.2.5.1
Build ID: 1:5.2.5~rc1-0ubuntu1~yakkety0
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; 
Locale: fa-IR (fa_IR); Calc: group

Fella has also sth to say:
https://forum.kde.org/viewtopic.php?f=289&t=138864
Comment 14 Buovjaga 2017-02-09 19:22:10 UTC
(In reply to Hamid from comment #13)
> How to check for the driver? This is how far I got in few minutes:
> 
> $lshw -C display
> …
> configuration: driver=i915 latency=0

Hmm, now this is getting confusing. You do not have modesetting. I get the same result as you and I have xf86-video-intel.

Pieter and the person on the KDE forum said 5.3 is better. Would be interesting to hear your result with 5.3.
Comment 15 Buovjaga 2017-02-10 06:44:38 UTC

*** This bug has been marked as a duplicate of bug 103676 ***
Comment 16 pieter kristensen 2017-03-21 14:13:30 UTC
Created attachment 132046 [details]
also with Ubuntu the sidebar can look ugly

Until now I was under the impression that this was a KDE thing. I see now that that isn't the case. Under Ubuntu the same happens.
And given the fact that this whole thing started when they dropped the old xserver-xorg-video-intel driver I am even more convinced that that is where it goes wrong.

Synaptic tells me that in Ubuntu the driver xserver-xorg-video-intel-HWE-16.04 is installed.
Comment 17 pieter kristensen 2017-04-15 17:31:54 UTC
I installed both ubuntu 17.04 and kubuntu 17.04 and all problems are solved. Libreoffice is rendered as it should.
I suppose this is due to the newer mesa verion.
Great!
Comment 18 pieter kristensen 2017-05-27 18:21:36 UTC
Created attachment 133652 [details]
sidebar late may 2017 newest HWE kernel mesa 17.2 (oibaf ppa)

I am now looking at LO 5.4. beta 1. KDE Neon, newest HWE kernel, and mesa 17.2 from the oibaf ppa.
Still the sidebar is a mess.
I'm starting to think it is purely a libreoffice issue. Otherwise the problem should have been gone in this software-setting.
Comment 19 Buovjaga 2017-05-27 18:37:48 UTC
(In reply to pieter kristensen from comment #18)
> Created attachment 133652 [details]
> sidebar late may 2017 newest HWE kernel mesa 17.2 (oibaf ppa)
> 
> I am now looking at LO 5.4. beta 1. KDE Neon, newest HWE kernel, and mesa
> 17.2 from the oibaf ppa.
> Still the sidebar is a mess.
> I'm starting to think it is purely a libreoffice issue. Otherwise the
> problem should have been gone in this software-setting.

And what about 5.4 beta 1 in Kubuntu or Ubuntu 17.04?