Bug 105395 - Footer Altered for some pptx after opening in Impress: Master Object is displayed and it should not
Summary: Footer Altered for some pptx after opening in Impress: Master Object is displ...
Status: RESOLVED DUPLICATE of bug 146223
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: interoperability
Keywords: filter:pptx
: 133154 (view as bug list)
Depends on:
Blocks: PPTX-MasterSlide
  Show dependency treegraph
 
Reported: 2017-01-17 19:24 UTC by Haleh Alemasoom
Modified: 2022-02-14 14:56 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
original vs altered footer image + slide (1.36 MB, application/zip)
2017-01-17 19:24 UTC, Haleh Alemasoom
Details
document (599.18 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2017-01-17 21:38 UTC, Xisco Faulí
Details
comparison (266.30 KB, image/png)
2017-01-17 21:40 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Haleh Alemasoom 2017-01-17 19:24:40 UTC
Created attachment 130503 [details]
original vs altered footer image + slide

1. open the attached slide in Impress
2. the footer is altered compared to the one in Microsoft powerpoint
Comment 1 Xisco Faulí 2017-01-17 21:38:44 UTC
Created attachment 130505 [details]
document
Comment 2 Xisco Faulí 2017-01-17 21:40:50 UTC
Created attachment 130506 [details]
comparison
Comment 3 Xisco Faulí 2017-01-17 21:43:40 UTC
master slide contains the grass image in the bottom.

Confirmed in

Version: 5.4.0.0.alpha0+
Build ID: 36afb355ac37122d32d624db079def123ef548a2
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

and

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 4 Cor Nouws 2017-01-18 12:03:44 UTC
Uncheck Slide > Display Master Objects and the situation is the same.
Comment 5 Buovjaga 2019-09-29 12:16:28 UTC
(In reply to Cor Nouws from comment #4)
> Uncheck Slide > Display Master Objects and the situation is the same.

This fixed the problem for me now.

Version: 6.4.0.0.alpha0+ (x64)
Build ID: e1b51d4588b4b39592bb94dd5bb90de5e04d061e
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@62-TDF, Branch:master, Time: 2019-09-23_09:16:11
Locale: fi-FI (fi_FI); UI-Language: en-US
Calc: threaded
Comment 6 NISZ LibreOffice Team 2021-01-22 07:33:04 UTC
*** Bug 133154 has been marked as a duplicate of this bug. ***
Comment 7 Gabor Kelemen (allotropia) 2022-02-14 14:56:05 UTC
This looks good now since:

https://git.libreoffice.org/core/+/4574a1ea408c2ac30042dca32d02207ec7add4da

author	Tibor Nagy <nagy.tibor2@nisz.hu>	Tue Dec 14 14:44:15 2021 +0100
committer	László Németh <nemeth@numbertext.org>	Mon Jan 03 13:41:41 2022 +0100
tree 968c3acb4ae910a8a4b82804c2d656922775876f
parent 87db920b141fe9846cbd1b37fff3a9806a9b5c2d [diff]

tdf#146223 PPTX import: fix master objects visible property

*** This bug has been marked as a duplicate of bug 146223 ***